PDA

View Full Version : Newbie first impressions / usability issues



pescobar
8th May 2006, 11:40 PM
Fedora Core 5, DVD downloaded via bittorrent a couple of weeks ago, version number not listed in System - About Fedora.

Please forgive spelling mistakes, I usually use google toolbar to spellcheck my posts, but new installation - no googlebar, sorry.

Installation:
Absolutely perfect. Completely friendly, detected my (modern to cutting edge) hardware without any problems, and happily used the 100GB of unpartitioned space on a 160GB hdd (60GB WinXP partition).

Playing around on the desktop. Perfect, really simple. Lack of a default sound scheme, nothing major, and I'm sure a pro could setup a sound scheme in 30 seconds, or an amateur after 3 minutes.

Internet: Firefox, outstanding, already familiar with it on Windows (as I'd guess any Windows convert to Linux would be), so no problems. Much more familiar with it than with Konqueror on the pendrive / live CD linux's I've tried in the past. FC5 works perfectly with DHCP and my router.

After the first few minutes the high levels of usability get a bit iffy.

I look through /mnt/ and a few other places to see if I can see the files on the other partition of this drive, the install program recognised the NTFS partition, and I vaguely remember reading on /. that it's difficult to write to NTFS, but reading was safe. Can't find an easy way to see the other partition.

Then I try to login to a PC on my home network, I need to install tightVNC (1.3dev7), the binary is only available for FC3, so I downloaded the Java version. It's a zip file which automatically opens, or has an "Extract Here" context menu (would prefer an "Extract Here to Folder (zip name)", but only a very minor complaint), Archive Manager looks nice and easy to use, very similar to a variety of Windows Zip programs, and nicer than WinRar.

Next I need to update Java, seems strange, since tightVNC1.3dev7 was released about 9 months ago, but I'm assuming Java has some licencing or open source issues. Firefox helpfully points me to the site to download Java from.

I try both the RPM version and normal, both are supposedly self extracting .bin files. Clicking a .bin by default tries to open it in a text editor. Then I right click on the file and choose "Open With...", unsure what to try, but Add/Remove Software is at the top of the list. Unlikely to work, I'd guess it's the same as Add/Remove programs in windows, but that never appears on Open With, so I guess it's worth a try.

Nope, not that one, didn't work.

Maybe Archive Manager, the file is supposed to be self extracting, but can probably be opened this way. Nope, didn't work.

Maybe I just need to run the file? Like a DOS command. Open With ... Terminal. Nope, that just brings something on the taskbar for a few seconds and vanishes, no input, output or error message seen by me.

While I'm sure I can find out how to extract a self extracting .bin file, (major geek background) I'm pretty sure a typical clueless office worker / CEO would by now be moaning and wanting Windows back the first time they experienced something counter-intutitive. Something like installing VNC is an expert only thing, I can understand problems, but some things are the defacto standard, and rightly or wrongly are installed on just about every machine, Flash, Java, and to a lesser extent Shockwave and ffdshow or similiar multipurpose codec/pack. Installing those should be pretty much idiot proof, and if codecs can be made less hassle than in Windows then even better.

And a final thing, more a note to the admin(s) of this forum, to register I've already had to type in obscured machine unreadable text, is it *really* necessary for my to validate my email too? That would've required replugging my RAID array and booting to windows, or setting up my emails to come to this installation, which would be a choir since it's easier to keep all my emails in one place, and expecting someone to setup pop3 before being able to ask a question seems a bit scary.

I know many new users to this forum won't have a freshly installed OS, or will use webmail, but you're the top site in google, and listed in the firefox toolbar, I'd assume fedoraforum.org is the 1st support site visited by a vast majority of Fedora newbies.

(This login was found on the very useful bugmenot.com)

---

Reading through my post it looks like I'm a whiny n00b, which may even be correct, but I'm also a fan of good, intutitive usability (Design of Everyday Things (http://www.amazon.com/gp/product/0465067093/002-5530115-0725626?v=glance&n=283155)) and thought that the first problems a newbie experiences would be useful to know.

dshaw256
9th May 2006, 12:21 AM
Assuming the .bin file is a Linux executable (and I'm sure it is, I just have this nagging thought that Windows also supports self-extracting .bin files)...

Step 1 - Make sure it's executable. Easily done by opening a terminal, moving to the directory, and using ls -l. See if the "x" attribut is set. If not, chmod +x <filename> will take care of that.

Step 2 - Execute the file with ./<filename>

I would venture to say that extracting the file is the easy part. Linux package installation from an RPM or using yum is usually very simple, but package installation "by hand" can be challenging. You might do better to look for a pre-built RPM.

I've been using FC4 for about a month and I find the GUI bits to be totally intuitive. Once you get to something that requires a shell, however, you are in old-time Unix land and things are not all that intuitive, imho. It's a learning experience.

pescobar
9th May 2006, 01:11 AM
Thank you Dave.

Spot on, the file needed +x.

Still doesn't work though :)

I've tried both Linux 32 and 64 RPM's (AMD Sempron) from here (http://java.com/en/download/manual.jsp), both have the same problem:

"Error resolving dependances"
Missing Dependency: java-gcj-compat >= 1.0.31 is needed by package xalan-j2
Missing Dependency: java-gcj-compat >= 1.0.31 is needed by package (big bunch of stuff)

At this point though I'm deservedly heading towards a RTFM, but I thought that the community at large should be aware of (presumably common) problems experienced by a typical newbie trying to make a bog standard web / email / office PC.

At the moment there is no way I'd recommend FC5 to a tech-illiterate windows user :(

---

One other thing I should've mentioned in my first post: a vast improvement, assigning partitions automagically, I used to hate having to guess how big usr / var / swap / etc should be, when I'd not really got a clue what goes where.