PDA

View Full Version : Citrix ICA Client install on Fedora



cmilhaus
8th May 2006, 06:47 PM
I'm a hobby level lover of Linux, and I am attempting to install the Citrix ICA rpm file on Fedora Core 5.0.
Every time I attempt to do the install, it fails saying that there is a depedency issue with libXm.so3. I have Googled the dickens out of this and am still coming up empty.
This is not an urgent request, but could anyone aho has some infomration to share on this, please share it. The browser I am useing is Firefox 1.5.02 which wass just updated today.
Thanks

scotta3234
8th May 2006, 07:08 PM
Citrix is a thin-client/remote desktop software correct? I belive there are some alternatives you could use such as FreeNX. Not exactly sure what you're using it for though. Have you tried to install/update that particular package using yum?

cmilhaus
8th May 2006, 07:19 PM
The client is used to remote to my office, which I can do from Windows. I am working with our Citrix Administrator to see if this can be done via Linux, and he suggested trying to get Citrix working in Fedora Core 5.0

Have you tried to install/update that particular package using yum? I have not. Not sure how to proceed.

Thanks

brunson
8th May 2006, 07:24 PM
http://support.citrix.com/forums/thread.jspa?messageID=460435

shadab5
13th December 2009, 10:08 AM
Heyy for a complete 'HOW TO' on installing Citrix client on Fedora, visit my blog post at http://ow.ly/LrDX

Regards,
Shadab

rexbinary
13th December 2009, 07:35 PM
Anyone have Citrix working under Fedora 12? The version 11 client won't launch at all for me on Fedora 12, but worked without issue on Fedora 11. Here is the output:



$ /usr/lib/ICAClient/wfcmgr -icaroot /usr/lib/ICAClient
/usr/lib/ICAClient/wfcmgr: line 197: Agreement: command not found

shadab5
14th December 2009, 03:44 PM
Hi,

I have used the same method in Fedora 12 too as mentioned at http://ow.ly/LrDX

For me it works fine in Fedora 12 also !!

Regards,
shadab

rexbinary
14th December 2009, 04:13 PM
Found the solution for me on F12.

I installed the ICAClient-11.0-1.i386.rpm with RPMFusion enabled, so it installed the OpenMotif package and other dependencies automatically. Also, I did not have to change fonts nor disable SELinux.

The fix for me was:


$ touch ~/.ICAClient/.eula_accepted

standbypowerguy
26th February 2010, 08:15 PM
Try this:

http://webmail.scatterpated.net:10080/index.php?name=News&file=article&sid=5

secroft
7th November 2010, 03:00 PM
I just installed Fedora 14 and wanted to get the ICA client running. After a little bit of work, it is functional. But instead of using the npica.so, I just associated the *.ica file with wfica.sh located in /usr/lib/ICAClient. What led me to this was the following error:

LoadPlugin: failed to initialize shared library /usr/lib/ICAClient/npica.so [/usr/lib/ICAClient/npica.so: wrong ELF class: ELFCLASS32]

I did see several posts on the web on how to fix it related to libraries but came up empty. The other issue I ran into was the Entrust root certificates. The solution to that was to download the certs from https://www.entrust.net/downloads/root_request.cfm and choose for personal use. Copy both the .der and .cer files to /usr/lib/ICAClient/keystore/cacerts then link the .cer to .crt and all should work

Ryman
29th November 2010, 11:40 PM
I just upgraded my system from F13 to F14 and can not longer launch Citirx ICA files. I have always removed the cjkuni fonts and it has worked but, not this time. The Citrix Receiver launches fine but there are no names to any for the ICA files and they will not launch in the receiver or from the web interface. With in the console it is complaining about missing fonts:


Warning: No font found.
Warning:
Name: FONTLIST_DEFAULT_TAG_STRING
Class: XmRendition
Conversion failed. Cannot load font.


any help would be greatly appreciated.

benji
1st December 2010, 01:16 AM
Hi Ryman,


I had same error after running updates on my F13 system. Problem was caused by an openjdk update. It brought down a host of fonts as dependencies. It is one of these fonts that has caused the problem. I am pretty sure this is the same problem you have. Have isolated the offending font: sazanomi-mincho. This font will have to be uninstalled.

If you run as root:

rpm -evv sazanami-mincho-fonts --nodeps

you will hopefully find this will fix your problem.

Ryman
1st December 2010, 08:43 PM
Thank you Benji that did seem to fix something. Now I am able to log in to the Citrix Receiver and see the fonts there for the application names but, sill unable to launch any published apps.
Again, within the console I get a new error:


Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Error: Aborting: no fontset found


All of my cjkuni-uming fonts are still disabled.

---------- Post added at 02:43 PM GMT ---------- Previous post was at 02:15 PM GMT ----------

Got it!!
Found that in a console if I ran LANG=C at the prompt then launched Citrix from that command window it worked fine.
So I edited the /usr/lib/ICAClient/wfcmgr file and added a line at the top LANG=C
Seems to be working fine now.