PDA

View Full Version : newbie on Wine with FC



digimars
8th May 2006, 03:59 PM
Hello,
I installed wine via 'yum install wine' from my command prompt on a new
install of Fedora Core 5 (everything was updated via yum before I
attempted this), and everything went well with that. Then, when I
tried to install a game that I saw was in gold status on the apps db,
it went through a list of fonts and installed them or something, but it
wont install the game. The CD is mounted, but this is all I get:
"[root@localhost Kenny]# wine /media/ELITEFORCE/setup.exe
wine: Unhandled page fault on write access to 0x7fd5be82 at address
0x11ef:0x000002f2 (thread 000a), starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg --auto 8 116")
(2)
Read the Wine Developers Guide on how to set up winedbg or another
debugger
err:ntdll:RtlpWaitForCriticalSection section 0x7fcfe3a0 "syslevel.c:
Win16Mutex" wait timed out in thread 0009, blocked by 000a, retrying
(60 sec)
[root@localhost Kenny]#"

Am I missing something? What do I need to do to get Wine to work?

jcliburn
8th May 2006, 11:56 PM
Did you run winecfg after installing wine (and before installing the game)?

digimars
9th May 2006, 02:16 AM
Yeah, I got winecfg to work, it detected OSS for my sound system (even though my Amarok uses Alsa). Had to use the demo32.exe file on the CD to get the game to install, but no sound. Wine puts desktop icons on my desktop, that when I double click them it says that I need the CD in the drive, which it is and it is mounted. So I tried to run the game from the demo32.exe file, same response. Then to check sound, I put an audio CD in (Tool's new album, rocks out) and it plays fine. So I uninstalled the game, changed my sound system to Alsa under winecfg, reinstalled the game (music plays during the installation and during the demo32.exe game menu on windows, so that's how I know that there is no sound) and I still can't hear anything during the install process.

jazzyjerome
10th November 2006, 05:28 AM
How do you install a game under wine?