PDA

View Full Version : k3b cd burning problem



nnylip
6th May 2006, 07:46 PM
I am trying to burn a cd with k3b. Debugging out is:

System
-----------------------
K3b Version: 0.12.14

KDE Version: 3.5.2-0.1.fc5 Red Hat
QT Version: 3.3.5
Kernel: 2.6.16-1.2096_FC5
Devices
-----------------------
PLEXTOR DVDR PX-740A 1.00 (/dev/hda, ) at [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-R; DVD-RW; DVD-R DL; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R Sequential; DVD-R Dual Layer Sequential; DVD-R Dual Layer Jump; DVD-RW Sequential; DVD+RW; DVD+R; DVD+R Double Layer; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96R; RAW/R16; RAW/R96R; Restricted Overwrite; Layer Jump]

Used versions
-----------------------
cdrecord: 2.1.1a03

cdrecord
-----------------------
/usr/bin/cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hda'
devname: '/dev/hda'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.85-RH '@(#)scsi-linux-sg.c 1.85 05/05/16 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
/usr/bin/cdrecord: Operation not permitted. Cannot send SCSI cmd via ioctl
Cdrecord-Clone 2.01.01a03-dvd (x86_64-unknown-linux-gnu) Copyright (C) 1995-2005 Jörg Schilling
NOTE: This version contains the OSS DVD extensions for cdrtools and thus may
have bugs related to DVD issues that are not present in the original
cdrtools. Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla The original cdrtools author should
not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 3
Capabilities :
Vendor_info : 'PLEXTOR '
Identifikation : 'DVDR PX-740A '
Revision : '1.00'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x0009
Profile: 0x002B
Profile: 0x001B
Profile: 0x001A
Profile: 0x0016
Profile: 0x0015
Profile: 0x0014
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009 (current)
Profile: 0x0008

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hda speed=40 -dao driveropts=burnfree -eject -data /home/lou/Desktop/ubuntu-5.10-live-amd64.iso

---------------------------------------------------------------------------

Some permissions :

-rwxr-xr-x 1 root root 377656 Feb 15 04:11 /usr/bin/cdrecord

-rwxr-xr-x 1 root root 3872968 Mar 21 13:21 /usr/bin/k3b

It will burn if run as root. Same thing happens with gnomebaker

Any help would be appreciated. Thanks - Lou

SuperNu
6th May 2006, 08:05 PM
There seems to be some issues with newer Linux kernels and cd/dvd recording. Here (http://forums.fedoraforum.org/forum/showthread.php?t=101102) is a thread which discusses some problems. There is an update for growisofs in updates testing that allows a non root user burn dvds. Have you tried to run k3b as root? You should be able to burn that way.

--SN

nnylip
7th May 2006, 04:25 PM
Thanks - I read the multiple threads involved here, but I don't see a clear conclusions. Is it only I that is having this problem and if not 1) is there a clearly documented solution and 2) why doesn't the ferdoa crew fix it as it seems semi rudimentary. If any one has a fix, please post it - Lou

space_cadet
7th May 2006, 05:06 PM
Your are not alone, a lot of people using Plextor drives have this problem (and not only Plextor users, some NEC users reported same problem). There is bug entry at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179862. The problem is that cdrecord does not work when invoked by normal user. So, gnomebaker, nautilus-cd-burner do not work if started as normal user. There is no elegant workaround for this problem, yet! I burn as root and for now that's it.

nnylip
7th May 2006, 07:12 PM
Thanks for the update, space_cadet, at least my expectations are set! Is there a dynamic way to see if this bug is addressed or should one keep checking the bug report? Thanks - Lou

daneel971
2nd June 2006, 08:46 AM
My 3 NEC dvd burners originally refused to work with cdrecord for cds (and I used cdrdao, which in turns had no problem at all) while my LG worked fine; for DVD of every type, growisofs worked perfectly. What I did in the attempt to fix that was simply to add a udev rules setting mode 666 for the optical devices, and it worked.
My software:
FC5, kernel 2.6.16-1.2122_FC5
K3b 0.12.15 (selfmade rpm)
growisofs 6.1 (selfmade rpm)
cdrdao-1.2.1-1
cdrecord-2.01.01.0.a03-3

MaegRil
30th June 2006, 07:51 PM
Man, that sucks!
I have a brand new Plextor PX-760A - I thought I was getting something good, looks like I got nothing but hassle.

I do hope this problem will be fixed sometime soon-ish?

mklose
21st January 2007, 03:51 PM
I see most people have burning problems as normal users, but I have problems even as root!
Here's the debug output... Any help would be greatly appreciated :p


System
-----------------------
K3b Version: 0.12.17

KDE Version: 3.5.5-0.2.fc6 Fedora-Core
QT Version: 3.3.7
Kernel: 2.6.19-1.2895.fc6
Devices
-----------------------
PIONEER DVD-RW DVR-109 1.58 (/dev/hdc, ) at [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-R; DVD-RW; DVD-R DL; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R Sequential; DVD-R Dual Layer Sequential; DVD-R Dual Layer Jump; DVD-RW Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; DVD+R Double Layer; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; 限制的覆寫; Layer Jump]

Used versions
-----------------------
growisofs: 7.0

growisofs
-----------------------
:-( unable to anonymously mmap 33554432: Resource temporarily unavailable

growisofs command:
-----------------------
/usr/bin/growisofs -Z /dev/hdc=/tmp/kde-root/k3b_image.iso -use-the-force-luke=notray -use-the-force-luke=tty -dvd-compat -speed=12 -use-the-force-luke=bufsize:32m

William Haller
18th March 2007, 09:50 PM
If you haven't solved your problem via google yet - try...

ulimit -l unlimited

before starting k3b.

mklose
22nd March 2007, 12:18 PM
If you haven't solved your problem via google yet - try...

ulimit -l unlimited

before starting k3b.
Ooops! doesn't work either~ :(

mklose
22nd March 2007, 12:26 PM
I just found this on another forum: Linux Questions.org, by hbush:
"In K3B, go to settings -> configure K3B -> writing -> advanced and set Manual writing buffer size to something between 10 to 16 Mb."
And it worked for me.