PDA

View Full Version : audio issues with mplayer



KC2OTE
6th May 2006, 12:30 AM
I am trying to use mplayer to view video files and I'm having difficulties getting the audio to work. It works fine with .avi files but not with .mpg or .wav.

When I try to view the file using mplayer at the command line I get:
MPlayer dev-Fedora-GS-CVS-060418-04:13-4.1.0 (C) 2000-2006 MPlayer Team
CPU: Advanced Micro Devices (Family: 15, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.


Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Playing 2.mpg.
MPEG-PS file format detected.
VIDEO: MPEG1 416x304 (aspect 1) 24.000 fps 740.0 kbps (92.5 kbyte/s)
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 32000 Hz, 2 ch, s16le, 56.0 kbit/5.47% (ratio: 7000->128000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
open: No such file or directory
vo_mga: Couldn't open /dev/mga_vid
open: No such file or directory
vo_mga: Couldn't open /dev/mga_vid
tdfxfb: can't open /dev/fb0: No such file or directory
================================================== ========================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 416 x 304 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
================================================== ========================
AO: [oss] 32000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 416 x 304 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 416x304 => 416x304 Planar YV12
A: 20.8 V: 20.8 A-V: -0.005 ct: 0.128 486/486 3% 1% 0.3% 5 0

Exiting... (End of file)


Can anyone help me??

Thank you.