PDA

View Full Version : Boot issue with FC5



poindexter
5th May 2006, 06:38 AM
FC5 was working fine until I added Debian to by box. It is a tri boot with XP, FC5 and Debian. Only the FC5 is not booting.

I have tried playing around with fstab and menu.lst with no success. Here are some details.

]# cfdisk -Pt /dev/hda

---Starting--- ----Ending---- Start Number of
# Flags Head Sect Cyl ID Head Sect Cyl Sector Sectors
-- ----- ---- ---- ---- ---- ---- ---- ---- ----------- -----------
1 0x80 1 1 0 0x07 254 63 1023 63 30716217
2 0x00 254 63 1023 0x0F 254 63 1023 30716280 63022995
3 0x00 0 0 0 0x00 0 0 0 0 0
4 0x00 0 0 0 0x00 0 0 0 0 0
5 0x00 254 63 1023 0x83 254 63 1023 63 30716217
6 0x00 254 63 1023 0x82 254 63 1023 63 2040192
7 0x80 254 63 1023 0x83 254 63 1023 63 30266397


Debian menu.1st

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 5

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda7 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,6)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## ## End Default Options ##

title Debian GNU/Linux, kernel 2.4.27-2-686
root (hd0,6)
kernel /boot/vmlinuz-2.4.27-2-686 root=/dev/hda7 ro
initrd /boot/initrd.img-2.4.27-2-686
savedefault
boot

title Debian GNU/Linux, kernel 2.4.27-2-686 (recovery mode)
root (hd0,6)
kernel /boot/vmlinuz-2.4.27-2-686 root=/dev/hda7 ro single
initrd /boot/initrd.img-2.4.27-2-686
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hda5.
title Fedora Core release 5 (Bordeaux) (on /dev/hda5)
root (hd0,4)
kernel /boot/vmlinuz-2.6.15-1.2054_FC5 root=/dev/hda5
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hda5.
title Fedora Core release 5 (Bordeaux) (on /dev/hda5)
root (hd0,4)
kernel /boot/vmlinuz-2.6.16-1.2080_FC5 root=/dev/hda5
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hda5.
title Fedora Core release 5 (Bordeaux) (on /dev/hda5)
root (hd0,4)
kernel /boot/vmlinuz-2.6.16-1.2096_FC5 root=/dev/hda5
savedefault
boot


Fedora menu.1st

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,4)
# kernel /boot/vmlinuz-version ro root=/dev/sda5
# initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=10
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.16-1.2096_FC5)
root (hd0,4)
kernel /boot/vmlinuz-2.6.16-1.2096_FC5 ro root=LABEL=/ rhgb quiet

initrd /boot/initrd-2.6.16-1.2096_FC5.img
title Fedora Core (2.6.16-1.2080_FC5)
root (hd0,4)
kernel /boot/vmlinuz-2.6.16-1.2080_FC5 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.16-1.2080_FC5.img
title Fedora Core (2.6.15-1.2054_FC5)
root (hd0,4)
kernel /boot/vmlinuz-2.6.15-1.2054_FC5 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.15-1.2054_FC5.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1


Debian /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda7 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0


Fedora /etc/fstab

LABEL=/ / ext2 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=SWAP-sda6 swap swap defaults 0 0



I booted into the rescue cd and got the following error when trying to get into the file system


An error occurred trying to mount some or all of your system. Some of it may be mounted under /mnt/sysimage

Next, I tried to upgrade the FC5 and got this error:


Multiple devices on your system are labeled /. Lables across devices must be unique for your system to function properly

Sorry for the long post but I wanted to get all the details in. I am a noob and have been working on this for a week. Any help is appreciated.

Thanks

poindexter
6th May 2006, 05:01 AM
I am about to give up on this one and re-install. Google has not really helped and I am stumped.

poindexter
8th May 2006, 05:29 AM
Anybody have any idea???

Seve
8th May 2006, 06:20 AM
Anybody have any idea???
Hello:
I found this from an old post..dunno if it applies to you or not but worth a shot. Since one of the errors you are encountering is :
Multiple devices on your system are labeled /. Lables across devices must be unique for your system to function properly


disk "labeling" problem, where you have two partitions labeled as "root" (see also /boot/grub/grub.conf and /etc/fstab).

That is almost certainly a showstopper, you will have to change the volume label on the disk, and in both of the files mentioned above for at least ONE of your Linux installs.
http://forum.fedoraforum.org/showthread.php?t=42880&highlight=tri+boot
Seve

Omega Blue
8th May 2006, 09:39 AM
Are you having multiple copies of grub?

Mektub
8th May 2006, 04:52 PM
Anybody have any idea???

First, I dont think there is any reason to have 2 menu.lst files.
When you initialize Grub, sayng f.e.:

grub> root (hd0,n)
grub> setup (hd0)

only the menu.lst of partition 'n' matters.

Also you should not have the same label for different partitions. Check with:

e2label /dev/hda2 (etc)

Hope this helps,

Mektub

Firewing1
8th May 2006, 05:02 PM
You should have Fedora's set to this:

title Fedora Core (2.6.16-1.2096_FC5)
root (hd0,4)
kernel /boot/vmlinuz-2.6.16-1.2096_FC5 ro root=LABAL=/ quiet
initrd /boot/initrd-2.6.16-1.2096_FC5.img
Or, even better:

title Fedora's GRUB
root(hd0,4)
chainloader +1
Firewing1

poindexter
10th May 2006, 01:48 AM
I am taking a look at some of the suggestions and will try them. Just to clarify, I had FC5 installed and then I installed Debian. During the Debian install I also re-installed Grub. The FC5 files above are there just for refernce since the Debian Grub over wrote it.

I think there are multiple problems, one with grub and the other with the 2 labels being the same.

Firewing1
10th May 2006, 01:57 AM
The 2 labels being the same will do it.
Firewing1

poindexter
10th May 2006, 02:52 AM
I am still a noob. How would I change the label?

Mektub
10th May 2006, 03:26 AM
For example for disk HDA partition 2:

See the label:

e2label /dev/hda2

(output is the existing label)

Set new label:

e2label /dev/hda2 newlabel

(new label will be the word 'newlabel')

Mektub

Firewing1
10th May 2006, 04:01 AM
You'll need to be root though. To become root, do:
su -then type your commands.
exitexits the root session when you're finished.
Firewing1

poindexter
29th May 2006, 08:58 PM
Thanks for your help. I ended up just doing a new install of FC5 and Grub. FC5 and XP booted just fine. Debian did not boot but it as simple as editing Grub. Thanks again.