PDA

View Full Version : Yum...bye bye! !?



fizy
4th May 2006, 08:44 PM
Yum is mad..... everytime i run a full-update this give me tons of errors.... related to KDE.... like kmultimedia! :mad: :mad:

axelseap
4th May 2006, 09:00 PM
are u using non-standard repos? it's probably caused by yum trying to update one package from one repo with a package from a different repo. this can cause errors because that first package might be split into 2 in that repo but not in the other.

fizy
4th May 2006, 09:08 PM
are u using non-standard repos? it's probably caused by yum trying to update one package from one repo with a package from a different repo. this can cause errors because that first package might be split into 2 in that repo but not in the other.
i've add only repo from .. :rolleyes: ... FEDORA4-FAQ....(=this site... :p )

axelseap
4th May 2006, 09:10 PM
what's the repos name? also, post the output from yum so the offended packages can be seen.

fizy
4th May 2006, 10:20 PM
okay... :(

brunson
4th May 2006, 10:34 PM
You've mixed livna and atrpms. You may as well just pour a bottle of bleach and a quart of ammonia into the toilet. I wouldn't recommend either.

You may be able to get around the problems by removing the failed packages and reinstalling them after a successful update, that's worked for me in the past.

fizy
4th May 2006, 10:57 PM
can you tell me what should i write?
yum remove <?>

btw, tnx! :D

Phoenix49
5th May 2006, 07:20 AM
Delete atrpms repo from /etc/yum.repos.d/ folder, and try to update. I think the best use is fedora base repos + livna + gstreamer repo.

fizy
5th May 2006, 12:04 PM
Delete atrpms repo from /etc/yum.repos.d/ folder, and try to update. I think the best use is fedora base repos + livna + gstreamer repo.Delete? :eek: :eek:
Why can't i only disable it? :rolleyes:

fizy
5th May 2006, 12:10 PM
Btw, don't work.... :(

I get:
Missing Dependency: libakode.so.2()(64bit) is needed by package kdemultimedia-extras
Missing Dependency: kdemultimedia = 6:3.5.1 is needed by package kdemultimedia-extras
Missing Dependency: libakode.so.2()(64bit) is needed by package akode-extras

Phoenix49
5th May 2006, 12:24 PM
Why you need to disable, if you will never use it ? ;) (in case u 'll use livna)

fizy
5th May 2006, 12:25 PM
Why you need to disable, if you will never use it ? ;) (in case u 'll use livna)i was with both.... :rolleyes: :p
Btw, the error still there...anyway... :confused:

Phoenix49
5th May 2006, 12:31 PM
Amm.. the easiest way - is to reinstall ;).

ccrvic
5th May 2006, 12:40 PM
Delete? Why can't i only disable it?

atrpms change quite a few things when they build their RPMs; you will end up with all sorts of compatability issues (like you're seeing now).

IMO, you either use atrpms exclusively, or not at all. I wouldn't mix that repo with anything else...

Vic.

ccrvic
5th May 2006, 12:43 PM
Btw, don't work.... :(

I get:
Missing Dependency: libakode.so.2()(64bit) is needed by package kdemultimedia-extras
Missing Dependency: kdemultimedia = 6:3.5.1 is needed by package kdemultimedia-extras
Missing Dependency: libakode.so.2()(64bit) is needed by package akode-extras


You've probably got a whole load of atrpms code already installed.

Remove atrpms from your repo list, and try :

yum list extras

Vic.

ccrvic
5th May 2006, 12:44 PM
Amm.. the easiest way - is to reinstall

Only if you've made a *complete* pig's ear of it all.

Adding a few RPMs from a different repo doesn't come close.

Vic.

fizy
5th May 2006, 11:02 PM
okay, i've run
yum list extras :confused: :confused: :confused:

brunson
8th May 2006, 04:45 AM
yum remove akode-extras kdemultimedia-extras

Then try the update again. Then, never mix 3rd party repos unless you really know what you're doing. I find livna, dag and dries *usually* behave together, but then again, I really know what I'm doing.