PDA

View Full Version : 2.6.16-1.2107_FC5 is needed by package



OperatorOne
4th May 2006, 05:18 PM
At the risk of sounding like a complete idiot, I am moving from Windows to Linux as I am simply tired of dealing with Microsoft. Fedora Core rocks and I have been making a slow transition over the last few months. I had FC5 running on my T43 just great, but it took a dive, so now I am using a t42 and I am having an issue I cannot seem to work around.

I have installed and run the yum update to make sure I have everything up to date, and I downloaded the kernel and kernel-devel packages with yum, but when I attempt to install any kernel mods, like for my ATI chip or drives to read my USB NTFS drive, I get this message....

Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna [1/4]
updates [2/4]
core [3/4]
extras [4/4]
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kmod-ntfs.i686 0:2.1.26-5.2.6.16_1.2107_FC5 set to be installed
--> Running transaction check
--> Processing Dependency: ntfs-kmod-common = 2.1.26 for package: kmod-ntfs
--> Processing Dependency: kernel-i686 = 2.6.16-1.2107_FC5 for package: kmod-ntfs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ntfs-kmod-common.noarch 0:2.1.26-2.lvn5 set to be updated
--> Running transaction check
--> Processing Dependency: kernel-i686 = 2.6.16-1.2107_FC5 for package: kmod-ntfs
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.16-1.2107_FC5 is needed by package kmod-ntfs


Can someone please assist me in solving this issue so I can get my ATI and NTFS drivers installed, and toss my Windows XP installation in the trash. :D

Thanks,

OperatorOne

P.S. This board is a great resource, and the people here rock.

pparks1
4th May 2006, 05:53 PM
typically when something like that happens;

yum clean all

And then try again.

OperatorOne
4th May 2006, 06:05 PM
Yeah I tried that and it's didn't seem to fix it. It's almost as if it thinks I have a different kernel installed. I am currently using 2.6.16-1.2096_FC5, basically I took most of the defaults for the DVD install (office, webserver, development) and then ran the yum updater to bring it all up to speed. Everything has installed flawlessly so far, including my ipw2200BG driver, and my wireless smokes.

OperatorOne
4th May 2006, 06:11 PM
Just FYI, I went to the HTFS project homepage and grabbed the RPM for NTFS module on 2.6.16-1.2096_FC5, but I am unable to track down an rpm for my graphics card. So I still need to resolve this. hehe. Is there a kernel update in the works and my yum.conf is somehow gummed up? I used the directions I found on this site.... http://www.fedorafaq.org/ to setup my yum application and was able to get most of the things on the list to operate as they are described, cept for the graphics driver and a few others that are giving me that error listed in the above post.

blue13130
4th May 2006, 06:26 PM
Just go to the livna site and download the kmod-fglrx rpm for the 2.6.16-1.2096_FC5 kernel and install that. Here is the link:
http://rpm.livna.org/fedora/5/i386/

This might be the RPM that you want:
http://rpm.livna.org/fedora/5/i386/kmod-fglrx-8.24.8-1.2.6.16_1.2096_FC5.i686.rpm

OperatorOne
4th May 2006, 07:07 PM
K. After banging on it for an extended period of time... I managed to get it to resolve itself. Basically I removed the kernel-devel package and reinstaleld it. then when I used "yum install kmod-fglrx", it properly resovled the deps and is currently downloading the kernel updates and all of the modules it needs.

<shrug> For a second there Fedora was begining to act like Windows! ACK! hehe.