PDA

View Full Version : Long delays starting up, and starting most programs.



LionKimbro
4th May 2006, 03:21 PM
I get long (27 second) delays:

Logging in from the login screen. (Graphic only; NOT from shell.)
Starting programs such as gnome-terminal, gedit.


...but I don't get long delays when:

I use EMACS, or Firefox.
I just login at the shell (i.e. Ctrl-Alt-F1.)
I start the system as root.


Pulling up gnome-terminal, I get a 27 second delay. If I've already started a terminal, and make a new one from there via File | Open Terminal. Then, it starts instantaneously. But if I type "gnome-terminal" at the prompt, it takes 27 seconds again.

I have run "strace gnome-terminal" as a normal user, and I see the following:



socket(PF_FILE, SOCK_STREAM, 0) = 10
uname({sys="Linux", node="shada.org", ...}) = 0
connect(10, {sa_family=AF_FILE, path="/tmp/.ICE-unix/10479"}, 22) = 0
fcntl64(10, F_SETFD, FD_CLOEXEC) = 0
write(10, "\0\1\0\0\0\0\0\0", 8) = 8
read(10, "\0\1\0\t\0\0\0\0", 8) = 8
access("/home/lion/.ICEauthority", R_OK) = 0
open("/home/lion/.ICEauthority", O_RDONLY) = 11
fstat64(11, {st_mode=S_IFREG|0600, st_size=1464, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7fe5000
read(11, "\0\4XSMP\0\0\0$local/shada.org:/tmp/."..., 4096) = 1464
read(11, "", 4096) = 0
close(11) = 0
munmap(0xb7fe5000, 4096) = 0
write(10, "\0\2\1\1\6\0\0\0\0\0\0\0\0\0\0\0\3\0MIT\0\0\0\3\00 01.0"..., 56) = 56
read(10, "\0\3\0\t\1\0\0\0", 8) = 8
read(10, "\0\0\0\000107e", 8) = 8
access("/home/lion/.ICEauthority", R_OK) = 0
open("/home/lion/.ICEauthority", O_RDONLY) = 11
fstat64(11, {st_mode=S_IFREG|0600, st_size=1464, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7fe5000
read(11, "\0\4XSMP\0\0\0$local/shada.org:/tmp/."..., 4096) = 1464
close(11) = 0
munmap(0xb7fe5000, 4096) = 0
write(10, "\0\4\1\1\3\0\0\0\20\0\0\0\0\0\0\0\360&f_\24\312\377<\337"..., 32) = 32
read(10, "\0\6\0\t\2\0\0\0", 8) = 8
read(10, "\3\0MIT07e\3\0001.0f00", 16) = 16
fcntl64(10, F_GETFD) = 0x1 (flags FD_CLOEXEC)
fcntl64(10, F_SETFD, FD_CLOEXEC) = 0
fstat64(10, {st_mode=S_IFSOCK|0777, st_size=0, ...}) = 0
fcntl64(10, F_GETFL) = 0x2 (flags O_RDWR)
access("/home/lion/.ICEauthority", R_OK) = 0
open("/home/lion/.ICEauthority", O_RDONLY) = 11
fstat64(11, {st_mode=S_IFREG|0600, st_size=1464, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7fe5000
read(11, "\0\4XSMP\0\0\0$local/shada.org:/tmp/."..., 4096) = 1464
read(11, "", 4096) = 0
close(11) = 0
munmap(0xb7fe5000, 4096) = 0
write(10, "\0\7\1\0\7\0\0\0\1\1\0\0\0\0\0\0\4\0XSMP\377<\3\0MIT_Z"..., 64) = 64
read(10, "\0\3\0\t\1\0\0\0", 8) = 8
read(10, "\0\0MIT07e", 8) = 8
access("/home/lion/.ICEauthority", R_OK) = 0
open("/home/lion/.ICEauthority", O_RDONLY) = 11
fstat64(11, {st_mode=S_IFREG|0600, st_size=1464, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7fe5000
read(11, "\0\4XSMP\0\0\0$local/shada.org:/tmp/."..., 4096) = 1464
close(11) = 0
munmap(0xb7fe5000, 4096) = 0
write(10, "\0\4\1\0\3\0\0\0\20\0\0\0\0\0\0\0\360&f_\24\312\377<\337"..., 32) = 32
read(10, "\0\10\0\1\3\0\0\0", 8) = 8
read(10, "\7\0GnomeSM\0001.\6\0002.14.16752", 24) = 24
write(10, "\1\1\1\0\1\0\0\0\0\0\0\0\0\0\0\0", 16) = 16
read(10, <unfinished ...>


I interpret this to mean:

There is an interaction by way of ICE.
ICE authenticates.
It's requesting ICE sub-protocol #1.
It's getting no response for a very long time.


If anyone can help, I'd be incredibly thankful.