PDA

View Full Version : NO Sound With Kernel-2.6.4



linux
1st April 2004, 03:10 AM
Hi all

i just upgraded my Kernel to 2.6.4 and it is soo sweeeeeeeeet ... BUT .. there is no sound.. everytime i reboot the system, i get this message saying that it cant detect my sound card

this is my card infos

Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)

if anyone knows whats the problem .. PLEASE respond

F*(#&$#*& windows

gonzalo76
1st April 2004, 06:11 AM
Go to, under KDE, Preferences + Control Center + Sounds & Multimedia + Sound System + Hardware and in 'Select and configure audio..., Select audio device and choose 'Open Sound System' or 'Alsa".

Then go to 'General', and check sound.

Good Luck

linux
1st April 2004, 07:04 AM
it is not helping
this is what i get :

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.

proffit
1st April 2004, 08:29 AM
The newer kernels all use the alsa sound driver. Try typeing alsaconf at the command line. You can go to www.alsa-project.org to download the alsa driver if you don't have it. I hope this helps you out.

Michael

linux
1st April 2004, 05:23 PM
i already installed alsa

and i tried that command 'alsaconf;
but it is not working

im about to give up

gonzalo76
1st April 2004, 05:51 PM
Try, as root, with

alsamixer

linux
1st April 2004, 10:46 PM
command not found

what im i doing wrong

any ideas guys?

this is how my /etc/modules.conf file look like

alias eth0 via-rhine
alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd
alias sound-slot-0 cmipci
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

linux
1st April 2004, 10:49 PM
got it got it

this is what was wrong

alias sound-slot-0 cmpci

and i changed it to cmipci and it just worked

thx all for the help

gonzalo76
2nd April 2004, 02:43 AM
Great, I'm glad you could fix it !!!

This is my modules.conf, I have audigy mp3+ sound card.

alias eth0 tulip
alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd
alias ieee1394-controller ohci1394

# OSS original portion
#alias sound-slot-0 audigy
#post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
#pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-emu10k1
options snd-emu10k1 snd_extin=0x0003 snd_extout=0x1f0f
post-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
pre-remove snd-card-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Did you try with

alsamixer
or if you prefer a GUI interface, gnome-alsamixer, http://www.paw.co.za/projects/gnome-alsamixer/ for me this was my solution cause I use digital output.

linux
2nd April 2004, 04:11 AM
yeah i did try it

but it didnt work

gonzalo76
2nd April 2004, 05:30 AM
But, how do you change your master volume level?

mhelios
2nd April 2004, 08:39 AM
alsamixer and friends are provided by the alsa-utils package.

rinux
23rd May 2004, 12:19 AM
I edited my modules.conf and changed it to snd-cmipci and now it works.

There is also a comment in modules.conf to make changes in another file which I also did. Sorry I can't remember the file name right now but you should see it when you edit modules.conf.

thx all for the help