PDA

View Full Version : Yet another K3b problem for FC5



Mainty
4th May 2006, 12:15 PM
Hi all,

I have installed FC5 recently on my laptop TOSHIBA and I got some trouble with K3b:
I cannot continue multisession disc. I always got the following message:
-----
Could not retrieve multisession infrormation from disk
The disk is either empty or not appendable.
-----

I've seen this problem at different linux forums, and I've already tried some solutions posted by people e.g
http://mandrivausers.org/index.php?act=ST&f=22&t=26077&st=0#entry190847
http://www.redhat.com/archives/fedora-list/2006-April/msg04482.html

Yet, none of them works for me. :confused:

Does anyone have any idea? Or is it a bug in K3b + FC5?

Thanks,
Mainty

Jongi
30th July 2006, 08:37 AM
I am faced with the same problem:
When burning the initial CD, under the Settings tab I have the options set as:

Datatrack Mode: Auto
Multisession Mode: Start Session

Then when I try to add, I click on the Import Session from Appendable Data. Add the new files and change the Multisession Mode to Continue Session. Same error as the initial post.

This is using a CD-R on a DVD-RW drive.

Mainty
31st July 2006, 09:20 AM
Actually, this problem is caused by the cdrecord version which goes with FC5. I solved mine by installing an old version of cdrecord.

All you have to do is the following:
1-) uninstall nautilus-cd-burner (if it is installed),
==> yum remove nautilus-cd-burner

2-) uninstall K3b,
==> yum remove k3b

3-) uninstall cdrecord,
==> yum remove cdrecord

4-) install an old version of cdrecord (e.g. I installed the one which goes with FC4: cdrecord-2.01-0.a19.2.i386.rpm),
==> rpm -ivh cdrecord-2.01-0.a19.2.i386.rpm

5-) Now, re-install K3b (FC5 version).
==> rpm -ivh k3b-0.12.15-0.1.fc5.kde.i386.rpm

I used the above version of K3b but any latest version might work. Note also that you may need to install the following packages as part of dependencies with K3b:
- libsamplerate-0.1.2.3.fc4.i386.rpm
- libsndfile1-1.0.13-7.rhfc5.at.i386.rpm
- tablib-1.4-2.fc5.i386.rpm

Hope that helps!

Jongi
31st July 2006, 03:31 PM
Will give this a bash. Do you remove k3b ahead of cdrecord due to dependency issues? eseentially is it not possible to just uninstall the current cdrecord and install the one you recommend.

Jongi
31st July 2006, 06:12 PM
Also I suspect at the next update yum will want to update cdrecord. How can I mark it as an un-updateable package?

Jongi
31st July 2006, 06:20 PM
That didn't work, installed cdrecord-2.01.1-9.0.FC4.1.i386.rpm.

EDIT: Your exact version seems to have solved my multisession problems.

Thanks

Jongi
15th September 2006, 12:51 PM
Has this multisession problem been resolved in newer cdrecord versions?