PDA

View Full Version : Uninstall aiglx



tud
2nd May 2006, 04:45 PM
Can you help me in uninstalling aiglx?
It's not working with my ati video card :mad: and I would like to go back to use livna fglrx ati driver.

thanks

newfc2user
2nd May 2006, 05:37 PM
Check out http://fedoraproject.org/wiki/RenderingProject/AiglxOnFedora

It has instructions to disable AIGLX (Stop the bling..) . If you want to completely get rid of everything, I am afraid you will have to remove the rpm you downloaded and re-install the stock FC5 ones.

tud
2nd May 2006, 05:58 PM
Check out http://fedoraproject.org/wiki/RenderingProject/AiglxOnFedora
It has instructions to disable AIGLX (Stop the bling..) .
I disabled it but I don't have 3d anymore because I cannot use "fglrx" driver and I'm forced to use "ati" driver


Check out
If you want to completely get rid of everything, I am afraid you will have to remove the rpm you downloaded and re-install the stock FC5 ones.
The problem is used the instructions from the wiki page you suggested me and I used the repository. Looking at the repository files http://download.fedora.redhat.com/pub/fedora/projects/aiglx/i386/ you can see that there are many Xorg related rpms. It means I should downgrade Xorg but I have no idea how to do it.
I'd like to know if there is any chance before reinstalling the system
Thanks

newfc2user
3rd May 2006, 03:36 AM
I am not sure I understand why you say you cannot use "fglrx" driver. Can you not edit the /etc/X11/xorg.conf file and put it in the Device section and restart X?

tud
3rd May 2006, 07:44 AM
I cannot use "fglrx" because if I use it in xorg.conf the X server doesn't start with the error (Xorg.0.log):

(EE) module ABI major version (0) doesn't match the server's version (1)
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(EE) No drivers available.

thank you foryour help

heymister
3rd May 2006, 05:32 PM
Hi,
you should be able to check the rpm installed from /var/log/yum.log and compare them with the rpms on the xgl repo; remove them and reinstall from core/updates repository.
I have the same problem; should be related to Xorg 7 and ati driver.
This night I'll roll back ( I have to play ET :-).
Post if you need help
Cheers
Marco

tud
4th May 2006, 10:11 AM
Following heymister's suggestions I solved my problem :) looking for packages I installed from http://download.fedora.redhat.com/p...cts/aiglx/i386 , deleting them with 'rpm -e --nodeps' command and finally reinstalling them with 'yum install' command

the two commands I used are:

rpm -e --nodeps gnome-terminal gtk2-engines libXcomposite libXcomposite-devel libdrm libdrm-devel mesa-libGL mesa-libGL-devel mesa-libGLU metacity vte xorg-x11-drv-ati xorg-x11-drv-i810 xorg-x11-proto-devel xorg-x11-server-Xorg
yum install gnome-terminal gtk2-engines libXcomposite libXcomposite-devel libdrm libdrm-devel mesa-libGL mesa-libGL-devel mesa-libGLU metacity vte xorg-x11-drv-ati xorg-x11-drv-i810 xorg-x11-proto-devel xorg-x11-server-Xorg


thanks Marco

commonplace
4th June 2006, 12:34 AM
Used this same process (substituting my own specific entries from yum.log) to remove the packages installed for AIGLX, and reinstalled with yum -- worked like a charm. Thanks!