PDA

View Full Version : VMWARE Server on Fedora 5 Core



consistgd
2nd May 2006, 04:09 PM
Tried to install VMWARE Server on FEDORA 5 Fore. The configuration script requries kernel headers to compile a kernel module. I could not find them. Installing kernel-devel package did not help. Anyone had experience with that?

icydog
2nd May 2006, 04:31 PM
I had problems with that until I downloaded a new vmware server rpm from the vmware site. Did you get the latest one?

consistgd
2nd May 2006, 05:30 PM
Yes, it is a week old (Dated April 25 2006). Fedora 5 is aslo of the same age. Do they have a newer one?
I ran installation from rpm and then config script. And script has default directory for kernel headers that does not exist. Do these headers always there?

sej7278
2nd May 2006, 06:38 PM
if you're using an smp kernel, it's kernel-smp-devel you need, i got it working with 2.6.16-1.2096

you seem to have to download the kernel-devel package every time you update your kernel, as yum doesn't seem to do it automatically (weird considering you already have it installed).

it's very important to use the latest vmware server package, i think it's beta 2 build 22874, and don't use vmware-anyany-update

once you get it installed, you have to edit these files (as root) to get it to work properly, as vmware-config-console.pl has a bug and vmware-config.pl lacks error checking needed on fedora/suse:

/etc/services (vmware-authd 902/tcp and vmware-authd 902/udp)
/etc/vmware/config (authd.client.port = "902")
/etc/xinetd.d/vmware-authd (Port = 902).

To get the MUI working I had to symlink the missing libdb.so.3 (ln -s /usr/lib/libdb.so.2 /usr/lib/libdb.so.3) then you connect to https://localhost:8333 in your browser