PDA

View Full Version : erreur: gdal_version.h



julien.63
2nd May 2006, 03:03 PM
Hi !
i'm on FC5.
I'm trying to install mapserver-4.8.1.
So i installed gdal-1.2.3 from a tar.gz.
i 've made :

[root@localhost mapserver-4.8.1]# ./configure --with-proj --with-gdal --with-ogr --with-gd
and
[root@localhost mapserver-4.8.1]# make
but i had
mapogr.cpp:142:28: erreur: gdal_version.h : Aucun fichier ou répertoire de ce type
mapogr.cpp: In function ‘int msOGRLayerGetAutoStyle(mapObj*, layerObj*, classObj*, int, long int)’:
mapogr.cpp:2185: attention : ‘oPenColor$red’ may be used uninitialized in this function
mapogr.cpp:2185: attention : ‘oPenColor$green’ may be used uninitialized in this function
mapogr.cpp:2185: attention : ‘oPenColor$blue’ may be used uninitialized in this function
mapogr.cpp:2185: attention : ‘oPenColor$pen’ may be used uninitialized in this function
make: *** [mapogr.o] Erreur 1

So do i need to install another thing, like gdal-devep for example?
Why this :
[[julien@localhost ~]$ rpm -ql gdal
le paquetage gdal n'est pas installé
says me gdal is not installed ?
Because i've installed from a tar.gz and i'm looking for a rpm?
If yes, how to check gdal is correctly installed?

thanks,

Julien

tashirosgt
2nd May 2006, 03:31 PM
Perhaps if you try pbone.net, you can find which package contains gdal_version.h.

ilja
2nd May 2006, 04:29 PM
try
yum provides gdal_version.h
maybe this helps to find the package you need.

Christy
2nd May 2006, 04:40 PM
Have you tried installing the FGS package? see http://www.maptools.org/fgs/

edit: is this the first time you are installing mapserver? or are you updating a previous install?

edit 2: oh ya, if you install FGS, don't install it as root....you'll probably end up with yum errors if you do (took me forever to figure that one out though)

edit 3: why are you installing gdal 1.2.3? there are more recent versions out there. (http://www.gdal.org/dl/ gdal-1.3.1, but I have never gotten it to install on FC5, and gdal-1.3.2b2 which I have gotten to install I think... but it's a beta version)

julien.63
2nd May 2006, 07:16 PM
- Yes, it's the first time i am installing mapserver.

- What's going to happen if i try install mapserver as i already have several librairies installed ?

- On your version gdal-1.3.2b2 do you have this file gdal-version.h ?

- what strikes me is that :
[julien@localhost ~]$ gdal-config --version
1.2.3


so here i have the version, but i don't know where does it come from ?

thanks
Julien

julien.63
2nd May 2006, 07:23 PM
i looked for in pbone.net but impossible to find this file. But it's a very interesting site i didn't know. :)

i tried :
[julien@localhost ~]$ yum provides gdal_version.h
Loading "installonlyn" plugin
Searching Packages:
Setting up repositories
core [1/3]
extras [2/3]
updates [3/3]
Reading repository metadata in from local files
Importing additional filelist information
Error: Caching enabled but no local cache of //var/cache/yum/core/filelists.xml.gz from core
[julien@localhost ~]$
but as you see, i have an error...

Julien

ilja
2nd May 2006, 07:26 PM
Try to do it as root, if it fails:
Try to do an


yum clean all

then an


yum update

you can answer n, if you don't want to update you system and try it again.

Is french the language of panama? I thought it was English or Spanish...

julien.63
2nd May 2006, 08:09 PM
You 're right, here one speaks english and spanish. But i'm french, so i still prefer setup my computer with french and use french keyboard as well. And i already have enough problems with software installations, so i try not to add useless difficulties ;)

i tried as root :


[root@localhost julien]# yum provides gdal_version.h
....
Added 805 new packages, deleted 0 old in 29.55 seconds
No Matches found

so i tried

[root@localhost julien]# yum clean all

[root@localhost julien]# yum clean update
...
Transaction Summary
================================================== ===========================
Install 3 Package(s)
Update 147 Package(s)
Remove 0 Package(s)
Total download size: 547 M
Is this ok [y/N]: N
Exiting on user Command
Complete!
[root@localhost julien]#

and

[root@localhost julien]# yum provides gdal_version.h
....
Added 805 new packages, deleted 0 old in 31.71 seconds
No Matches found

so i'm still looking for this bloody file :(

I saw, the fgs is using gdal-base. Does it have something different?

Julien

Christy
2nd May 2006, 10:52 PM
the FGS package has everything I have needed so far for web mapping applications. There is a package with just mapserver and another package that also includes chameleon. The thing that I like about FGS is that it installs everything to one directory, if something happens and you need to reinstall it, all you need to do is delete the one directory and the entries to a couple files (they set the environment up on startup...you'll see what I mean if you install it).

I would suggest trying to install it, and if something doesn't work all you have to do to get rid of it is delete the one directory. If you run into errors, post them and I'll try to help. I think there was some additional package that I needed to install, but for the life of me I can't remember what it was.

julien.63
2nd May 2006, 11:00 PM
ok i gonna try.
thx for your help
Julien