PDA

View Full Version : GTK / GLIB - Not Allowing XMMS to Start



seikiray
2nd May 2006, 08:25 AM
Hi -

On a FC3 system, with the intention of getting
XMMS up and running (XMMS apparently requires
a higher version of GTK than is available in RPM form):

I've downloaded and installed from source --

GTK+ 2.8
GLIB 2.8.6

And the dependencies (Pango, etc.).

Finally GTK compiles, but the source install
of XMMS 1.2.10 refuses to compile, giving
an error about the nonexistence of "gtk-config".

I've tried installing the wxGTK-devel RPM to
obtain the gtk-config file, to no avail.

If you have successfully installed XMMS from
scratch, please enlighten me. The problem
has already wasted at least five hours of my life --
and I can't survive without music! Links to the
needed RPMs would also be great.

Thanks in advance for your help.

P.S. I also installed Synaptic and tried installing
XMMS that way, also without success. Yum gives
the same result as well. Installing from RPMs
gives an error on XMMS startup -- "Sorry,
your GTK+ version (1.2.0) doesn't work with
XMMS. Please use GTK+ 1.2.2 or newer." Of course,
the latest GTK+ RPM seems to be 1.2.10-33.

Seve
2nd May 2006, 02:07 PM
Hello:
Does following this provide any help?
http://www.stanton-finley.net/fedora_core_3_installation_notes.html#MPlayer
Seve

seikiray
2nd May 2006, 04:10 PM
Hello:
Does following this provide any help?
http://www.stanton-finley.net/fedora_core_3_installation_notes.html#MPlayer
Seve

HI Seve,

I installed all of the gstreamer RPMs via Synaptic, as well as
all of the XMMS packages (-aac, -devel, -musepack, -skins, etc).

Still received the "old GTK" error.

"Sorry, your GTK+ version (1.2.0) doesn't work with XMMS.
Please use GTK+ 1.2.2 or newer."

Stranger still, I reinstalled XMMS from the install CD and
it still asks for a newer GTK. This is unusual because
XMMS was working fine a week ago (before the nightmare
that was installing VLC). After the VLC install, however,
XMMS refuses to work.

icydog
2nd May 2006, 04:45 PM
XMMS uses GTK+ not GTK2. GTK2 version 2.whatever won't work with XMMS. You have to use the old GTK,.

ftp://ftp.gtk.org/pub/gtk/v1.2/

For example, these are installed on my system:

gtk+-1.2.10-50
gtk2-2.8.17-1.fc5.1
glib-1.2.10-18.2.2
glib2-2.10.2-1.fc5.1

The 1.2.x and 2.x versions can coexist.

seikiray
2nd May 2006, 10:28 PM
XMMS uses GTK+ not GTK2. GTK2 version 2.whatever won't work with XMMS. You have to use the old GTK,.

ftp://ftp.gtk.org/pub/gtk/v1.2/

For example, these are installed on my system:

gtk+-1.2.10-50
gtk2-2.8.17-1.fc5.1
glib-1.2.10-18.2.2
glib2-2.10.2-1.fc5.1

The 1.2.x and 2.x versions can coexist.

Hi Icy.

This is the full error message:

========================

Gtk-WARNING **: Unable to locate loadable module in module_path: "libbluecurve.so",
Sorry, your GTK+ version (1.2.0) doesn't work with XMMS.
Please use GTK+ 1.2.2 or newer.

========================


The following packages are installed:

GTK+_
gtk+-devel-1.2.10-33
gtk+-1.2.10-33

GTK2_
gtk2-engines-2.2.0-6
gtk2-devel-2.4.14-4.fc3.3
gtk2-2.4.14-4.fc3.3

GLIB_
glib-devel-1.2.10-15
glib-1.2.10-15

GLIB2_
glib2-devel-2.4.8-1.fc3
glib2-2.4.8-1.fc3

XMMS_
xmms-aac-2.0-4.1.fc3
xmms-speex-0.9.1-3.1.fc3.fr
xmms-1.2.10-9.1.1.fc3.fr
xmms-lirc-1.4-3.1.fc3.fr
xmms-mp3-1.2.10-9.1.1.fc3.fr
xmms-crossfade-0.3.8-1.1.fc3.fr
xmms-musepack-1.1.2-1.1.fc3
xmms-xosd-2.2.12-1.1.fc3.fr
xmms-devel-1.2.10-9.1.1.fc3.fr
xmms-skins-1.2.10-9.1.1.fc3.fr
xmms-flac-1.1.0-7
xmms-acme-0.4.2-1.1.fc3.fr
xmms-wma-1.0.4-1.1.fc3

seikiray
3rd May 2006, 06:37 AM
I'm actually wondering if there is a GTK+ RPM that is higher than 1.2.0.

Has anyone found one?

If not, it's back to square zero.... and the original question.

seikiray
3rd May 2006, 07:57 AM
And then there was Amarok.

http://fedoraproject.org/extras/3/i386/repodata/repoview/amarok-0-1.2.4-1.fc3.html

Needed to install taglib:

http://rpm.pbone.net/index.php3/stat/4/idpl/2543182/com/taglib-1.3.1-1.fc3.i386.rpm.html

Probably won't bother with XMMS again until I upgrade to FC5.
Any new solutions would be welcome regardless.

And thanks for your help, Icydog and Seve.

seikiray
3rd May 2006, 05:48 PM
Just wanted to add --

Aqualung is even better.

http://aqualung.sourceforge.net/index.php?tab=home