PDA

View Full Version : Nautilus dropped application and file preview settings!



rgladwell
1st May 2006, 01:23 PM
Argh... for some reason my installation of Gnome has suddenly dropped the settings for opening my applications and file preview. Now, when I try to open my files in nautilus I no longer get a nice preview thumbnail.

http://forums.fedoraforum.org/attachment.php?attachmentid=8031&stc=1
http://forums.fedoraforum.org/attachment.php?attachmentid=8030&stc=1

Similarly, when I double-click to open a file nautilus has forgetten all the file associations and I get a "Couldn't display" error message. I have to re-associate the file type with it's preferred application. Similarly, when I open my Computer folder I get a jumble of ugly icons:

http://forums.fedoraforum.org/attachment.php?attachmentid=8029&stc=1

Is there anyway to restore the file associations and get nautilus to start properly displaying and opening my files? Has anyone seen this before? Please , please advise?

TIA...

Ricardo

code_astronomer
2nd May 2006, 09:43 PM
aaaa...I've just had this happen to me! I installed monodevelop (you can find the thread in the programming section). I have no idea how to fix this but just to let you know, you're not alone!

rgladwell
2nd May 2006, 10:02 PM
aaaa...I've just had this happen to me! I installed monodevelop (you can find the thread in the programming section). I have no idea how to fix this but just to let you know, you're not alone!
Ah, that makes sense. Someone should probably raise a bug or alert the monodevelop packager.

To fix this issue simply uninstall and reinstall nautilus and that seems to do the trick. Be careful, doing "yum erase nautilus" erases lots of other packages fundamental to gnome operation. Make sure you reinstall those as well.

code_astronomer
2nd May 2006, 10:45 PM
hmm..that has fixed some problems...however if I take a screenshot and save it to the desktop, the thumnail preview doesn't appear unless I right click on it...and then the icon suddenly changes and then it shows the preview ... :S
otherwise I just get a green gnome foot.

Also, I can't open my .png files..it tells me they could harm my pc

code_astronomer
3rd May 2006, 09:13 AM
Does anyone know how to stop this happeneing? (see attached image)
If I double click a .png that's what I get...is there a setting somewhere that will allow me to change this?

code_astronomer
3rd May 2006, 10:50 AM
ok...I kind of worked it out...I change the mime type from applicaiton to image in ~/.local/share/applications/default.list and it seems to work...if a bit slower than normal.

rshendershot
3rd May 2006, 12:24 PM
reinstall gnomevfs. I believe that is what worked for me.