PDA

View Full Version : Need help with building F-Spot 0.1.11 - FC 4



markitz
1st May 2006, 01:42 AM
When I try to compile F-Spot i get this message:


checking for Mono.Data.SqliteClient.dll... configure: error: missing required mono DLL: Mono.Data.SqliteClient.dll

I've installed mono, mono-devel and extras from the mono repo specified on the mono web page.

I allso searched for the RPMs but I could only find for either FC 3 or FC5 or other Linux distributions.

And, yes, I tried googleing and searched this forum but to no avail :(

markitz
1st May 2006, 11:31 AM
I did some more searching and I may be missing libmono-dev package.

I tried to search for it but I just can't find it. I found packages for Debian, Ubuntu and Solaris but none for Fedora Core.

GL1800
1st May 2006, 11:35 AM
Uh-huh. I tried that, too, on FC4, also tried beagle, never got either one to compile. After upgrade to FC5 both compile smoothly. Here's the mono "stuff" that ships with FC5:
mono-data-sqlite-1.1.13.4-2
mono-winforms-1.1.13.4-2
mono-core-1.1.13.4-2
mono-devel-1.1.13.4-2
monotone-0.26-1.fc5
mono-data-1.1.13.4-2
mono-web-1.1.13.4-2

I'm sure some of that is not needed for f-spot, but I am not sure exactly what. Also, I am unsure what things need to be in the libraries. All that remained an unsolved mystery until i left FC4.

markitz
1st May 2006, 12:15 PM
I did, again, some more searching and installed:


mono-data-sqlite

It now complains about the following:


checking for F... Package libexif was not found in the pkg-config search path.
Perhaps you should add the directory containing `libexif.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libexif' found
configure: error: Package requirements (libgnome-2.0 >= 2.2 libgnomeui-2.0 >= 2.2 libexif >= 0.5.7 libexif < 0.7.0 gtkhtml-sharp-2.0 >= 2.7 gconf-sharp-2.0 >= 2.7 glade-sharp-2.0 >= 2.7 gnome-vfs-sharp-2.0 >= 2.7 gtk+-2.0 >= 2.6 mono >= 1.1.7 dbus-sharp >= 0.23) were not met:



Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables F_CFLAGS
and F_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I have the libexif installed. The problem is I don't know how to change the enviromental variable PKG_CONFIG_PATH and to what :(

I know I need to do something with the pkg-config command, but those man pages are just so overhealming when viewed the first couple of hundred times :(

GL1800
1st May 2006, 12:21 PM
Yes, aren't they. However, this error is usually about the -devel packages. Do you have libexif-devel? What he's actually looking for is the .h header files.

markitz
1st May 2006, 03:26 PM
Thanks for the tip! I didn't have the libexif-devel package installed.

I installed it through yum and it now complains about gtkhtml-sharp-2.0. Checked with rpm -qa | grep -i gtkhtml-sharp and it told me that I have gtkhtml-sharp-1.0. Tried to update it via yum, but yum says there isn't anything that's marked for update/obselition.

I'm going to google a bit to try to find a direct link for gtkhtml-sharp-2.0 RPM.

Thanks for your help!

markitz
1st May 2006, 03:37 PM
I'm giving up, there's to many dependencies that need to be taken care of and yum can't help me :(

So much trouble for a 900kB program...

GL1800
1st May 2006, 03:40 PM
Uh-huh, i remember that. Here's whats in FC5
gtk-sharp2-2.8.2-1
gtk-sharp-1.0.10-5

I never found these for FC4

markitz
1st May 2006, 06:45 PM
I downloaded and compiled gthumb. It's supposed to be very similar to F-Spot.

It's very simple and user friendly - and works :)

Cheers!

grndplane
2nd May 2006, 03:15 AM
Try Digicam. It's been working good for me. I guess I am going to have to bite the bullet and install FC5.

markitz
2nd May 2006, 02:45 PM
Try Digicam. It's been working good for me.
Thanks for the info, will try it.

I guess I am going to have to bite the bullet and install FC5.
Yeah, me to...

GL1800
2nd May 2006, 02:48 PM
Digikam has become my favorite. I got it setup so that when the camera is sensed, it starts, and auto-unloads that puppy, which I think is just too cool.

markitz
2nd May 2006, 03:00 PM
Tried Digikam, it's a good program but it's made to work with cameras and making albums.

gThumb is a much better chioce for me, I just needed a browser/viewer.

Thanks, everyone!