PDA

View Full Version : Yum - Metadata file does not match checksum



hackerotaku
1st May 2006, 12:14 AM
If you get the following error while running yum the fix is very simple

Error Message: Metadata file does not match checksum

Run Fix as user root:

yum clean all
yum update

:D

beer_hunter
2nd May 2006, 09:35 AM
I've got this error from about 2 days, whe i tried to clean all , effect was the same:
Error Message: Metadata file does not match checksum

and this one is only with extras repository :S what to do?

hackerotaku
2nd May 2006, 01:57 PM
beer_hunter,

Looks Like I left out a step
Try this, this worked on my end to resolve this problem

yum clean all
yum makecache
yum update

beer_hunter
3rd May 2006, 10:32 AM
I tried with makecache and i've got the same error :(
any ideas how to fix it in this situation? :S

hackerotaku
3rd May 2006, 12:06 PM
Cut and Past Error OutPut so I can see the exact errors you are getting

beer_hunter
3rd May 2006, 12:18 PM
primary.xml.gz 100% |=========================| 249 kB 00:02
http://ftp.chg.ru/pub/Linux/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.

it's the same error for all mirrors :confused:

u-noneinc-s
3rd May 2006, 03:32 PM
I don't exactly know how yum handles the mirrors. Maybe it cycles through them? Anyway, I get the same error (also
with extras), and I have seen it try a dozen mirrors (aproximately) before it finds one that it likes. It'll mess up once, then
the next time I try it, it's fine, then it messes up again. Must be some bad mirrors. Happens with updates sometimes too,
but not so often.

When I run yumex, it doesn't display the errors, but sometimes it takes forever to load so I'm sure it's the same problem.

beer_hunter
3rd May 2006, 04:01 PM
yeah, i was trying about ~50 times, and then worked o.O thanx for help :)

jbannon
3rd May 2006, 08:58 PM
Here's what I find helps. If your running yumex set the mirror option to "best". this gives far fewer problems than leaving it as default or fastest. Takes a bit longer but is a lot more reliable.

sej7278
3rd May 2006, 09:05 PM
i think there's a serious problems syncing the extras mirrors, as freshrpms, dries, updates, core, monodevelop, dag, macromedia etc. all work fine.

Firewing1
3rd May 2006, 09:35 PM
i think there's a serious problems syncing the extras mirrors, as freshrpms, dries, updates, core, monodevelop, dag, macromedia etc. all work fine.
No, that's partially it but not the whole thing.
To reduce load, download.fedora.redhat.com (official host) contains the ~1kB checksum for the metadata. The metadata (usually ~1 - 2 MB) is downloaded off mirrors. After downloading metadata, Yum compares the two to make sure they're one and the same.
Now, think of this: download.fedora.redhat.com updates their metadata and checksums, so you're getting the new checksum. The mirror's cronjobs havn't gone yet, therefore no synching and the metadata isn't the newest, it doesn't match.

The solution is not to makecache; Although it may help it will take forever and still not 100% solve the problem. The main problem is not giving the mirrors enough synch time. Typically, cron runs every hour, and give it a bit of time to download the changes, so I'd say try running maybe 10 minutes after an hour and you'll have no problem (eg 3:10, 4:10, 5:10, etc...). If you get closer to :50 (3:50, :50, etc) you'll start seeing more syncing issues.

Again, this too isn't 100% perfect but more of a guideline. There's a lot of guesswork...

BTW - An easy way to bypass it is if you're not using that repo, disable it for the run with

yum --disablerepo=repoID [ install | update ] packagename

Firewing1

rshendershot
6th May 2006, 10:41 PM
beer_hunter,

Looks Like I left out a step
Try this, this worked on my end to resolve this problem

yum clean all
yum makecache
yum update


I was getting this a lot, making yum updates nearly unusable, until the last yum package update. If you're not using yum-2.6.1-0.fc5 then get that update. If you are and you're still getting the Metadata file does not match checksum erorr message, then check to see if you have yum-fastestmirror plugin installed. If you do, remove it.

This problem has completely gone away for me given these to "fixes"

HTH!
-rsh

mickza
27th June 2007, 03:16 PM
beer_hunter,

Looks Like I left out a step
Try this, this worked on my end to resolve this problem

yum clean all
yum makecache
yum update
I have just experienced similar problems for several days -


http://ftp.belnet.be/packages/dries.ulyssis.org/fedora/linux/5/i386/dries/RPMS/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from dries: [Errno 256] No more mirrors to try.

In the end I had to change the standard dries baseurl from:

http://ftp.belnet.be/packages/dries.ulyssis.org/fedora/linux/$releasever/$basearch/dries/RPMS/

to:

ftp://mirror.pacific.net.au/linux/freshrpms/dag/dries/fedora/linux/$releasever/$basearch/dries/RPMS/

and run the above before it came right.
(Im in South Africa and find the Australian sites better in general to the local ones hence my mirror choice).