PDA

View Full Version : xine controlling the system sound



uptonm
30th April 2006, 10:36 AM
Ok this might be a simple one for you people, but I'm on month 3 or so of using Linux, and don't know the system yet. This is driving me up the wall.

I was watching a video in Xine, and before I shut it off, I turned the sound down. Now Xmms got quieter, and so i figured.... hmmm maybe its Xine's fault, and so I went back into Xine while Xmms was running, turned the sound back up, and yep, it was Xine's fault. But immediately when I exited Xine, the sound went back down.

So I tried a myriad of diff combinations of shutting it down and running Xmms, went into the settings of Xine under audio and played with a couple settings, but it seemed no matter what I did, I open Xine, I can adjust the volume for the rest of the system. I close Xine, and the volume goes for everything else goes down. I can't figure it out. I'd sure appreciate help with this. :confused:

buddha
30th April 2006, 03:19 PM
I would suggest you go into Xine settings and set "Configuration Experience Level" to maximum ("Master of the known universe"). Then under the Audio tab, I would suggest changing either "device.alsa_mixer_name" (mine says "PCM") or "restore volume level at startup" or both.

I usually leave the Xine volume setting at max and use the gnome volume applet to control my overall sound levels.

uptonm
30th April 2006, 10:06 PM
well, i don't seem to have the restore volume level setting, i do have it set to PCM, and I'm not sure how I would go about changing it since there's no drop down menu... I wouldn't know what to type in there.

thanks for the reply

buddha
30th April 2006, 10:15 PM
Scroll down to the bottom and you should see the restore volume setting, or, you can edit xine options in the config file, ~/.xine/config

Look for this stanza,

# restore volume level at startup
# bool, default: 0
#audio.volume.remember_volume:0

uptonm
1st May 2006, 01:15 AM
OHHHHHH DUH! I didn't see the scroll bar... lol. Thanks, let me check it out

uptonm
1st May 2006, 01:21 AM
ok I clicked that setting to on, it was off before, and i changed the volume slider above it so it was louder... but I really wish Xine would just leave the system volume alone. I know winamp likes to do that too sometimes in Windows, I don't see the reason for it.

Its at an acceptable level now anyway, thank you. :)

THE Ralfinator
26th June 2006, 03:59 PM
I am having the same problem with xmms. When i had FC5 before,(from a FC4 upgrade) the system sound wasnt affected by programs. But now with a clean FC5 installation, XMMS thinks it can mess with my sound! :P

THE Ralfinator
26th June 2006, 04:02 PM
Not a bad desktop, by the way:)