PDA

View Full Version : HELP NEEDED with kernel update issues



achidlow
29th April 2006, 09:10 AM
hello, im pretty mmuch a newbie, so maybe im doing something stupidly wrong, so if i am please point it out kindly, and i have scoured the internet for other people with this problem for a couple of hours now and none can be found so i dont think its a bug, but all the same i really need some help fairly quickly with this before school starts again and i can no longer focus getting my transition from windows xp --> FC4 completed.
Anywho when i update my kernel, either via yum or RPM, i can no longer connect to the internet! I have tried this twice now, doing a fresh reinstall of the whole of FC4 after trying the RPM, and just now i have tried again via yum and have had to remove the newer kernel via yum.
My current kernel is the 2.6.11-1.1369_FC4 one that came with FC4, and i am trying to update it to 2.6.16-1.2096_FC4 kernel.
The installation and evrything goes of without a hitch but when i boot into the new kernel i cant connect to the internet. It recognises the card, says its there and all, but i cant ping myself, my router, www.google.com.au, or any website. also, i had a look round the back, and where the cat 5 is plugged in the orange light thats normally on when its plugged in didnt appear to be on. when i tried to browse the internet, it says "cant find (insert webist here). when i disable the device and re-enable it, it says it cant connect and to check that the cable is connected (which i did and it was fine, i hadnt touched it since 10 mins ago anyways under the older original kernel(2.6.11*), and it was working fine then, and i havent touched it since and its now forking on the same kernel (2.6.11*) please help someone? heres the output from some commands run using the current kernel (the 2.6.11 in case u havent been following):

[achidlow@localhost ~]$ arch
i686

[achidlow@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 i686 i386 GNU/Linux

[achidlow@localhost ~]$ /sbin/lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 651 Host (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
# (above is the 10/100 ethernet card that wont connect to our router with updated kernel)
00:0f.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)
# (in case ur wondering, the above is my wireless, which im still trying to get working under ANY kernel!!!)
00:10.0 Communication controller: Agere Systems (former Lucent Microelectronics) LT WinModem (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)

if you need to know anything else please ask, i wasnt sure what to put up. if you need output from using the kernel 2.6.16 then i could probably re-install it and run some commands for you. but PLEASE people i really need some help here, and it will be greatly appreciated if you culd contribute anything at all no matter wether there is a one in a billion chance it might work. thanks!

imdeemvp
29th April 2006, 09:37 AM
Which kind of connections are you seeking? wired or wireless? cable or dsl?

achidlow
29th April 2006, 09:48 AM
our connection is ADSL 1.5mbps download and 256kbps upload, i have an onboard LAN card as above, a SiS900 ethernet adapter, i am currently connected to our d-link DSL -G604T wireless router, which also has 4 connection thingys for that blue cable which is plugged into my computer and im connected to the first port, i think the correct terminology involves - RJ-45, Cat 5, UTP, stuff like that. its wired atm, ill get my wireless card working once everything else is (saving the biggest for last) if ur interested its a D-Link AirPlus DWL-G510 rev.b, specs: 54mpbs, b/g compatible, based on atheros ar5212 chipset, and under windows that works fine. but atm its more concering that with the latest kernel i cant connect to the internet, which will be required for me to get the wireless working, and thank you imdeemvp very much for your quick reply!

achidlow
29th April 2006, 11:13 AM
i have found something that might be causing some of the erorrs, this is from http://www.fedoraproject.org/wiki/YumUpgradeFaq :

Common Problems FC4 -> FC5
* Before upgrading, uninstall all kernels < 2.6.14, otherwise initscripts and a few other packages will conflict and prevent the ugprade.
* After upgrading, selinux permissions may be incorrect, causing interesting failures such as metacity not starting. As suggested below, to fix this, run
o /sbin/fixfiles relabel

seeing as FC5 comes with (i think) a 2.6.15 kernel, could this be related??? if so how on earth can you uninstall a kernel before installing a new one? i thought the kernel was required to do ANYTHING at all on linux, so how can you then install a new kernel??? forgive me if this is a dumb question

achidlow
29th April 2006, 04:10 PM
update: found a 2.6.14 kernel on an obscure ftp, and have succsefully updated to that. uninstalled 2.6.11 and now trying once more using yum to update to 2.6.16

achidlow
29th April 2006, 05:09 PM
woohoo! im posting this running the newest stable kernel!!! (2.6.16-1.2096_FC4) looks like it was a bug after all, i'd report it but im not sure how...

kioopi
5th July 2006, 11:16 AM
i think i'm havig the same problem.
could you please tell me where you got the 2.6.14 kernel?

that would be awesome.