PDA

View Full Version : FC5: fat32 partition wrongly mounted at boot time



jwiz
28th April 2006, 09:01 PM
I have a fat32 which should be auto-mounted with owner 'user' at startup, but Fedora Core 5 only mounts it as 'root' , disregarding my entry in /etc/fstab.
SELinux is disabled.

This is the respective entry in /etc/fstab:
/dev/hda7 /mnt/windows_e vfat auto,user,exec,umask=0022 0 0

If I unmount the parition (as root), I can remount it as user anytime.
The above fstab entry has worked for FC3 without any problems, now FC5 screws it up - but why?

Any ideas?

TIA
jwiz

Seve
29th April 2006, 12:45 AM
I have a fat32 which should be auto-mounted with owner 'user' at startup, but Fedora Core 5 only mounts it as 'root' , disregarding my entry in /etc/fstab.
SELinux is disabled.

This is the respective entry in /etc/fstab:
/dev/hda7 /mnt/windows_e vfat auto,user,exec,umask=0022 0 0

If I unmount the parition (as root), I can remount it as user anytime.
The above fstab entry has worked for FC3 without any problems, now FC5 screws it up - but why?

Any ideas?

TIA
jwiz
Not sure why, however try this:
/dev/hda7 /mnt/windows_e vfat users,defaults,umask=000 0 0

Seve

jwiz
29th April 2006, 10:14 AM
I have tried option 'users' already, but it doesn't make any difference.

Seve
29th April 2006, 11:46 AM
I have tried option 'users' already, but it doesn't make any difference.
Hello:
Not sure what the problem is then, as the line I gave to you is working on 3 FC5 machines that I have now?? I guess it's not an SELinux problem....dunno just a thought. :)
Seve

steve1961
29th April 2006, 12:08 PM
This is the fstab entry for a fat 32 partition on my ystem:

/dev/sda5 /media/sda5 vfat rw,user,umask=000 0 0


seems to work fine.

martyfelker
30th April 2006, 12:29 AM
Some kind soul on this forum offered a solution which I found works great for me. Sorry I can find you sir to give attribution.

Make a subdirectory in your own home folder for example /home/userid/windows. Since the userid has full rights to every file and folder in their home directory - the user has full read/write access to fat32 partitions. FSTAB something like

/dev/hda1 /home/userid/windows vfat defaults 0 0