PDA

View Full Version : gnome-power-manager



robghealey
28th April 2006, 01:23 AM
this is not a big issue at all. It is not really even an issue.

My desktop computer is always plugged into AC power. Is there a way to disable gnome-power-manager without having to delete the software package?

Firewing1
28th April 2006, 01:36 AM
Right click on it's icon > Preferences > Advanced (I think) > Never display Icon
BTW, gnome-power-manager 2.15.1 is out in Development and it's very stable, plus a bunch of cool new features! Check it out:

yum --enablerepo=development --enablerepo=development-extras update gnome-power-manager
Firewing1

robghealey
28th April 2006, 04:52 AM
Thank you. I am w/o internet connection right now. Are there any dependencies for the new gnome-power-manager that I need to be aware of. I can download the new gnome-power-manager from work and do an rpm -Uvh * from home.

Firewing1
28th April 2006, 09:43 PM
Start http://download.fedora.redhat.com/pub/fedora/linux/core/development/ there and work your way through - I'm not sure of your arch, but after you choose from PPC, PPC64, i386, or x86_64, proceed to the Fedora > RPMS directory, and download gnome-power-manager 2.15.
I checked, and there's no special requirements what so ever as far as I can tell.
Firewing1

Botond
2nd May 2006, 10:11 AM
gnome-power-manager will sometimes be started twice, sometimes with the "--sm-disable" option. This later causes problems, beacuse gnome-power-manager simply exits when I push the power button. Normally (without the --sm-disable option) gnome-power-manager displays a dialog and I'm offered to choose from possible actions when the power button is pressed.
Is there a way to inhibit gnome-power-manager being started with the "--sm-disable" switch?

(Btw, version 2.15.1 of gnome-power-manager displays 2.14.1 in the --help-all section.)

Firewing1
2nd May 2006, 09:49 PM
For the --help bug, file a bug report at bugzilla.redhat.com

Next, If you install the gconf editor you can edit apps > gnome-power-manager and then set it to display all the options.

For --sm-disable, Preferences > More Preferences > Session and under "Startup Programs" you'll find it there.

Firewing1