PDA

View Full Version : Anyone know how to get tftp server working?



samfraser
27th April 2006, 10:12 PM
I can't get tftp to start, any of you guys willing to give me some pointers?

cat /etc/xinetd.d/tftp
# default: off
# description: The tftp server serves files using the trivial file transfer \
# protocol. The tftp protocol is often used to boot diskless \
# workstations, download configuration files to network-aware printers, \
# and to start the installation process for some operating systems.
service tftp
{
disable = yes
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpboot
per_source = 11
cps = 100 2
flags = IPv4
}

As you can see below I'm not even listening for tftp!

netstat --proto=inet,inet6 -pnl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 2251/pure-ftpd (SER
tcp 0 0 0.0.0.0:23 0.0.0.0:* LISTEN 2218/xinetd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 2161/cupsd
tcp 0 0 :::80 :::* LISTEN 2235/httpd
tcp 0 0 :::21 :::* LISTEN 2251/pure-ftpd (SER
tcp 0 0 :::22 :::* LISTEN 2209/sshd
udp 0 0 0.0.0.0:68 0.0.0.0:* 1894/dhclient
udp 0 0 0.0.0.0:631 0.0.0.0:* 2161/cupsd

brunson
27th April 2006, 11:11 PM
disable = yes
Think that might be the problem?

Try "chkconfig tftp on", then you may or may not need "service xinetd restart".

samfraser
28th April 2006, 07:17 PM
I tried chaning it to "no" but it just changes back again when I try and start the service.

brunson
28th April 2006, 07:22 PM
..........

Try "chkconfig tftp on", then you may or may not need "service xinetd restart".

samfraser
10th May 2006, 10:37 AM
I've tried chkconfig tftp on and get no output. I then tried

service xinetd restart
Stopping xinetd: [ OK ]
Starting xinetd: [ OK ]

and ran chkconfig tftp on and get no output.


Any other ideas?

Jeff Sadowski
26th January 2007, 03:19 AM
This thread is probably pretty old but you may also want to check your firewall settings.
services iptables stop

and see if it works then if so it is a firewall issue