PDA

View Full Version : Rssowl not working



jmarius
27th April 2006, 06:37 PM
Is anybody having these error messages when trying to load feeds in Rssowl?
[marius@bigfoot ~]$ rssowl
Exception in thread "Update Manager Thread" java.lang.NullPointerException
at net.sourceforge.rssowl.util.CryptoManager.hasItem( CryptoManager.java: 125)
at net.sourceforge.rssowl.dao.ConnectionManager.<init>(ConnectionManager .java:89)
at net.sourceforge.rssowl.util.shop.FileShop.getConte nt(FileShop.java:20 2)
at net.sourceforge.rssowl.controller.thread.UpdateMan ager.getVersion(Upd ateManager.java:189)
at net.sourceforge.rssowl.controller.thread.UpdateMan ager.run(UpdateMana ger.java:117)
Exception in thread "Load Feed Thread" java.lang.NullPointerException
at net.sourceforge.rssowl.util.CryptoManager.hasItem( CryptoManager.java: 125)
at net.sourceforge.rssowl.dao.ConnectionManager.<init>(ConnectionManager .java:89)
at net.sourceforge.rssowl.dao.NewsfeedFactory.initXml Document(NewsfeedFa ctory.java:232)
at net.sourceforge.rssowl.dao.NewsfeedFactory.<init>(NewsfeedFactory.jav a:97)
at net.sourceforge.rssowl.dao.NewsfeedFactory.<init>(NewsfeedFactory.jav a:82)
at net.sourceforge.rssowl.controller.thread.FeedLoade r.run(FeedLoader.ja va:139)

(RSSOwl 1.2:26280): Gtk-CRITICAL **: gtk_message_dialog_new: assertion `parent = = NULL || GTK_IS_WINDOW (parent)' failed
Exception in thread "main" org.eclipse.swt.SWTError: No more handles
at org.eclipse.swt.SWT.error(SWT.java:2968)
at org.eclipse.swt.SWT.error(SWT.java:2865)
at org.eclipse.swt.SWT.error(SWT.java:2836)
at org.eclipse.swt.widgets.MessageBox.open(MessageBox .java:139)
at net.sourceforge.rssowl.controller.MessageBoxFactor y.showMessage(Messa geBoxFactory.java:91)
at net.sourceforge.rssowl.controller.GUI.runEventLoop (GUI.java:628)
at net.sourceforge.rssowl.controller.GUI.showGui(GUI. java:789)
at net.sourceforge.rssowl.controller.RSSOwlLoader.<init>(RSSOwlLoader.ja va:116)
at net.sourceforge.rssowl.controller.RSSOwlLoader.mai n(RSSOwlLoader.java :131)
After I shut it down, next time it starts it won't have any of the feeds listed. I delete the .rssowl folder and it comes back to normal, but I still can't load any feeds.

Iced.Empire
9th November 2006, 02:05 PM
Yes..Hello..

I have also the same Problem than you..

But I take for the while the rpm from the rssowl hp and it works....espacially without eclipse so you can remove it from the system.