PDA

View Full Version : unable to do update



michi
27th April 2006, 01:23 PM
When I'm starting the software-updater
he is working a moment (lesser than 1sec), and then producing
the error: "Unable to retrieve update information".

bob
27th April 2006, 02:13 PM
Are you using yum or pup or something else? Your best resource is to open a terminal and do 'yum update'. It's faster and if there's a problem it will give you more information about where the failure is. Sometimes a repository is offline and there can be a few hours of failures until things get straightened out.

michi
27th April 2006, 03:21 PM
I used pup, but yum also dosn't work:


[root@localhost ~]# yum update
Setting up Update Process
Setting up repositories
livna [1/7]
http://rpm.livna.org/fedora/5/i386/RPMS.stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Thu, 27 Apr 2006 14:12:51 GMT
Server: Apache/2.0.51 (Fedora)
Content-Length: 324
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: livna
failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from livna: [Errno 256] No more mirrors to try.

bob
27th April 2006, 03:42 PM
Livna seems to be having a few problems. Try 'yum --exclude=livna update'

michi
28th April 2006, 03:45 PM
This is also not working!

michi
28th April 2006, 03:52 PM
I have found the misstake:
In the file /etc/yum.repos.d/livna.repo:
instead of:
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/RPMS.stable/
it has to be:
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/

michi
28th April 2006, 04:01 PM
But it is still not working:
he can update:

Package sound-juicer.i386 0:2.14.3-1.fc5.1 set to be updated
---> Package gtk2.i386 0:2.8.17-1.fc5.1 set to be updated
---> Package ghostscript.i386 0:8.15.1-7.2 set to be updated
---> Downloading header for gnome-vfs2-devel to pack into transaction set.
gnome-vfs2-devel-2.14.1-1 100% |=========================| 36 kB 00:00
---> Package gnome-vfs2-devel.i386 0:2.14.1-1.fc5.2 set to be updated
---> Package glib2-devel.i386 0:2.10.2-1.fc5.1 set to be updated
---> Package gnome-pilot.i386 0:2.0.13-7.fc5.6 set to be updated
---> Package openoffice.org-javafilter.i386 1:2.0.2-5.7.2 set to be updated
---> Package gstreamer-plugins-base.i386 0:0.10.5-1 set to be updated
---> Package gnome-pilot-devel.i386 0:2.0.13-7.fc5.6 set to be updated
---> Package curl-devel.i386 0:7.15.1-3 set to be updated
---> Package librsvg2-devel.i386 0:2.14.3-1.fc5.1 set to be updated
but he is failing at 'arts' (and kernel and more):


---> Downloading header for arts to pack into transaction set.
http://ayo.freshrpms.net/fedora/linux/5/i386/updates/arts-1.5.2-0.1.fc5.i386.rpm: [Errno 14] HTTP Error 404: Date: Fri, 28 Apr 2006 14:50:39 GMT
Server: Apache/2.2.2 (Unix)
Content-Length: 333
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Error: failure: arts-1.5.2-0.1.fc5.i386.rpm from updates: [Errno 256] No more mirrors to try.

bob
28th April 2006, 05:33 PM
I've done 'yum search arts' and your missing version is in 'updates'. I'll post my 'updates' so you can see if yours is okay:

[updates]
name=Fedora Core $releasever - $basearch - Updates
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$releas
ever/$basearch/
mirrorlist=http://fedora.redhat.com/download/mirrors/updates-released-fc$release
ver
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[updates-debuginfo]
name=Fedora Core $releasever - $basearch - Updates - Debug
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$release
ver/$basearch/debug/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[updates-source]
name=Fedora Core $releasever - Updates Source
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$release
ver/SRPMS/

michi
28th April 2006, 09:37 PM
Sorry, I don't understand :confused: , perhaps you can give me more information or better a small HOW-TO configure yum, for downloading: the updates (particularly the Kernel) and livna.

PS: I liked the graphical Updater from FC3 more than pup of FC5: He was working well, fast and showing me how many updates there are; why isn't he in FC5 and can I install him (easy)???

michi
29th April 2006, 10:34 PM
is ther no way, have I realy to make everything manual per rpm and tarball?