PDA

View Full Version : Can't Log Out



webdevguy
26th April 2006, 07:31 PM
I've got an FC5 installation (with KDE) that I've been messing around with, and now I can't log out. Nothing happens when I click (I've tried more than once) on [menu] > Log Out... What can I look for to see why it is hanging, and how can I get it to log out?

u-noneinc-s
26th April 2006, 08:09 PM
Try a yum update.
Does cont+alt+backspace work?

webdevguy
26th April 2006, 08:28 PM
yum update comes up empty, because I have recently run pup. (I've got another FC5 machine that is also up-to-date, and clicking Log Out on that one does work.)

ctrl+alt+backspace works, but after shutting down and rebooting, clicking [menu] > Log Out still doesn't work.

webdevguy
26th April 2006, 08:32 PM
FWIW, the problem machine recently experienced an abrupt shutdown due essentially to a power cut off.

u-noneinc-s
27th April 2006, 01:15 AM
I have had this problem before (not exactly the same though) and I think it was an update that fixed it, but I really don't
remember now. I would have to logout twice. First attempt failed (returned to session), second attempt logged out.
After logging back in, all attempts to logout through the menu failed and it required a reboot to get back to needing 2
logouts and back to a reboot, etc... (I hate reboots).

Only a suggestion. Maybe mv /home/yourusername/.kde /home/yourusername/.kde.orig. Logout and when you login, KDE
should create a new .kde for you. See if you can now logout.

If you have problems logging in to kde (you shouldn't), you can go to gnome (or runlevel 3) and mv ~/.kde.orig back to
~/.kde.

I've had to do this once due to failed kde login

webdevguy
27th April 2006, 03:13 AM
That worked! I just renamed the directory, then did a ctrl+alt+backspace to log out. Then I logged back in, no problem. The desktop wallpaper, and the icon positions, needed re-doing, but I have no problem logging out from the K Menu.

As I think back, this problem probably began to manifest before the power shortage. It was sort of like how you described it, i.e., the first attempt to log out failed, but the second (or later) attempt worked. Perhaps the power failure was the final straw. Weird.

Anyway, thanks for your help!

u-noneinc-s
27th April 2006, 04:49 AM
I'd like to just say "welcome", but it wont accept a reply that short, so I have to type in a bunch of extra words to say it. ;) :p