PDA

View Full Version : ffmpeg - recording video, but no sound...



code_astronomer
26th April 2006, 06:40 PM
hello

I was experimenting with ffmpeg to record tv from my tv capture card...the only problem is, I can't get it to record sound.

The current command I run is:


ffmpeg -s 4cif -aspect 4:3 -vd /dev/video0 -ad /dev/dsp1 -ar 44100 -ab 64 -ac 2 -acodec mp3 -vcodec mpeg4 -target vcd ~/test.mpg


does anyone know what I can do to record sound?

for the audio device, I have tried:


/dev/audio
/dev/audio1
/dev/adsp
/dev/dsp
/dev/dsp1


Some extra info:
The sound cable from the TV Capture card is connected to the CD Audio Connector on the motherboard.
I have sound when I watch tv in tvtime.
I can record sound from my mic, but that's obviously not what I want.

code_astronomer
26th April 2006, 11:29 PM
I've been looking all over the web for a solution to this...it appears it is possible, but most of the articles/tutorials I have found are for older kernels.

Does anyone have any idea how I can record my sound? If I can hear it, surely I can capture it?

More info:
my tv card is WinFast 2000 XP Expert (I have simply plugged it in and started watching tv with it, so no drivers added...all in the latest kernel apparently...lsmod shows cx8800 and I think I did modprobe -v bttv too while following a tutorial...but things went a bit strange because my output was entirely different...

aaa...it's driving me mental.

I'm sure all I need is the correct audio device to feed in to my ffmpeg line...no?

code_astronomer
27th April 2006, 06:54 PM
ok, so it seems there isn't anyone that could help with the above question...

well, I finally managed to get audio but I have to start the recording using:

ffmpeg -vd /dev/video0 -vcodec mpeg4 -ad /dev/dsp -ar 44100 -ab 64 -ac 2 -target vcd ~/test.avi
then quickly open tvtime. If I don't open tvtime, then I get no audio...

perhaps someone might be able to help with my next question?

Is there a better way to do this? (preferably using ffmpeg or mencoder). The current method leaves me with out of sync audio and I can't watch what I am recording (tvtime has a blue screen due to the video stream being directed into ffmpeg (I presume) so I can only hear the sound that is being recorded...