PDA

View Full Version : PHP Problems...



wpatterson
25th April 2006, 02:04 PM
it appears there is a problem with the way PHP is compiled on a default FC4 installation. I am not able to run any forum software on my web site because of the following error "PHP Warning: preg_match: internal pcre_fullinfo() error -3". PHP.net will not accept this as a bug and explains that PHP5 has to be compiled with "--with-pcre-regex" NOT "--with-pcre-regex=/usr"

Is there a fix for this or am I going to have to install a different distro? :confused:
Any help is appreciated! :cool:

Jman
26th April 2006, 04:27 AM
Which forum software and where did you hear about the configure option?

FC4 php compiles with "--with-pcre-regex=/usr"

wpatterson
26th April 2006, 04:53 AM
any forum software, I've tried 4 completely different programs and every one of them spit out the error

"PHP Warning: preg_match: internal pcre_fullinfo() error -3 in /chroot/home/mpchostc/mpchost.com/html/forum/includes/template.php on line 392"

sometimes the line number changes, but its always a preg_match: internal pcre_fullinfo() error...

I recently found these threads that describe my problem:
http://bugs.php.net/bug.php?id=29914

This is a fresh install of Fedora Core 4.

Does this help? I would love to get this working..;)

wpatterson
26th April 2006, 04:55 AM
also, I'm using PHP 5.0.4