PDA

View Full Version : Fedora shuts down automatically



tseliot
24th April 2006, 11:19 AM
Hi, I have quite a problem. Fedora Core 5 (x86) shuts down automatically (randomly) after a few hours.

It just seems to decide that it has to shutdown (it doesn't crash!) just like I did a "shutdown -h now" (which I don't do).

here is my /var/log/messages:
messages (http://www.webalice.it/albertomilone/ubuntu/nvidia/messages)

here is my dmesg:
dmesg (http://www.webalice.it/albertomilone/ubuntu/nvidia/dmesg)
I'm using the latest kernel.

My CPU is an AMD 3500+

tomcat
24th April 2006, 11:44 AM
What temperatures does your system report? Maybe it is overheating and shutting down in order to avoid a burned cpu or mobo. I had experienced something like that many, many years ago. It was my gfx-card that was almost burning back then.

tseliot
24th April 2006, 01:27 PM
What temperatures does your system report?
How can I check that?

BTW that didn't happen in Fedora Core 4 as doesn't happen in Arch Linux (from which I'm writing) and Ubuntu Dapper.

tseliot
24th April 2006, 01:40 PM
Can this cause the problem?

powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.60.0)
powernow-k8: BIOS error - no PSB or ACPI _PSS objects

If so, perhaps recompiling the kernel without that feature or enabling Cool'n'quiet in the BIOS can solve the problem.

The_Archangel
24th April 2006, 03:38 PM
If you can live without having features like autmatically turning off monitor and having hard disks to be turned off if you're not working for a long time you could just try turning ACPI support off in BIOS.

tseliot
25th April 2006, 09:22 AM
If you can live without having features like autmatically turning off monitor and having hard disks to be turned off if you're not working for a long time you could just try turning ACPI support off in BIOS.
Unfortunately I need Fedora to run all day. Therefore I can't turn ACPI off.

I'll file a bug ASAP.

tomcat
26th April 2006, 06:10 PM
powernow-k8: BIOS error - no PSB or ACPI _PSS objectsCould well be, that this is one of the problems. For checking system temperatures, you would need to install and configure the lm_sensors package. Filing a bug should not hurt. :)

tseliot
27th April 2006, 10:06 AM
Thanks for your answers guys.

I have filed a bug here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190058

marko
27th April 2006, 10:28 AM
Originally Posted by The_Archangel
If you can live without having features like autmatically turning off monitor and having hard disks to be turned off if you're not working for a long time you could just try turning ACPI support off in BIOS.

Unfortunately I need Fedora to run all day. Therefore I can't turn ACPI off.

I'll file a bug ASAP.

Why does running Fedora all day mean you can't turn off acpi? Also, turning off the
monitor automatically has nothing to do with acpi, I think that's related to the
dpms support in the Xorg server and is not related to acpi
Mark