PDA

View Full Version : nTransaction Check Error when i try updates



carlainz
21st April 2006, 07:48 PM
Hi all
when i try to do updates from updates i have this error ...



/nTransaction Check Error: file /etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_applications_browser.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_applications_help_viewer.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_applications_terminal.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_background.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_file_views.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_interface.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_lockdown.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_sound.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_thumbnailers.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/gconf/schemas/desktop_gnome_typing_break.schemas from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/sound/events/gnome-2.soundlist from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1
file /etc/sound/events/gtk-events-2.soundlist from install of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1


thanks

dishawjp
21st April 2006, 08:59 PM
looks like you have two versions of libgnome installed. Verify this with the command:

rpm -q libgnome

It looks like you'll get two responses, something like this:

libgnome-2.14.1-1.fc5.1
libgnome-2.14.0-1

If that's the case, the command:

rpm -e libgnome-2.14.0-1

given by root should clear up your probelm.

Then you have to figure out how you got two versions of the same library installed and you probably should look to see if there are other files with multiple versions installed. You might want to try something like:

rpm -qa * > nnn | sort

and check the resulting file nnn for different versions of the same packages.

HTH,

Jim

carlainz
21st April 2006, 10:56 PM
[cab@localhost ~]$ rpm -q libgnome
libgnome-2.14.0-1
libgnome-2.14.0-1
[cab@localhost ~]$

probabily because i have installed i386 and x84_64 version
( i use FC5 x86_64 , with macromedia i386 )

there is a solution for this?

thanks

dishawjp
22nd April 2006, 01:05 AM
Wow,

You have two versions installed, but rpm is giving them the same name. I have no idea how you would remove the offending version and leave the proper one.

Sorry