PDA

View Full Version : Drive problems



JoeyJoJoe
21st April 2006, 02:42 PM
I have been trying to add more space to my fedora core 5 file system that contains the operating system, I've got less than 100MB now so I really need it as installing/updating is now not really possible. I've been given some good advice on how to use the unused sectors and create a new partition, which I did (/dev/hda4). I then added the new partition to the volume group. This seemed to work. The problem now is that I don't seem to have the space on my system and don't know what to do now. Below is a few things that I get when i run some stuff in root...


[root@a-202 ~]# fdisk -l

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 3166 25430863+ 7 HPFS/NTFS
/dev/hda2 4323 4335 104422+ 83 Linux
/dev/hda3 4336 4864 4249192+ 8e Linux LVM
/dev/hda4 3167 4322 9285570 83 Linux

Partition table entries are not in disk order

Disk /dev/sda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 10010 80405293+ c W95 FAT32 (LBA)

[root@a-202 ~]# pvdisplay
--- Physical volume ---
PV Name /dev/hda3
VG Name VolGroup00
PV Size 4.03 GB / not usable 0
Allocatable yes
PE Size (KByte) 32768
Total PE 129
Free PE 1
Allocated PE 128
PV UUID 5U0rWl-G0ZO-KUL5-10vt-Yq1M-SDKs-dHmPOO

--- Physical volume ---
PV Name /dev/hda4
VG Name VolGroup00
PV Size 8.84 GB / not usable 0
Allocatable yes
PE Size (KByte) 32768
Total PE 283
Free PE 283
Allocated PE 0
PV UUID APwymC-elJq-gADz-eoQl-Q7c8-dawy-dqV2ZM

[root@a-202 ~]# vgextend 'VolGroup00' /dev/hda4
Volume group "VolGroup00" successfully extended

So basically I would have expected this to work (I've restarted aswell - i thought it might load up next time) and I thought I would be able to see the new space... I might have just missed something really easy (being a noobie) but I would really appreciate any help you could give me, before I pull out all of my hair. Thanks.

tashirosgt
21st April 2006, 03:44 PM
You say that you can't "see the new space", but what command were you using to see it? Did you use df ?

JoeyJoJoe
21st April 2006, 04:01 PM
Well it's rather quite strange, when i say I can't see the new space I mean when I open up my home folder or look at my desktop it says that my free space is 54 MB, however when I ran that df command it said

"Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
3047184 2835272 54628 99% /
/dev/hda2 101105 17861 78023 19% /boot
tmpfs 257604 0 257604 0% /dev/shm
/dev/sda1 80248536 77945604 2302932 98% /media/EXHD"

have I done it wrong? I wanted to be able to use the free space from /dev/hda4 in order to have new parts of my OS on... I thought that what i'd done would let me do that, although I'm begining to doubt that. Is there any way I can get it sorted so i can use it with my OS files?

UPDATE: I now realise that this topic is probably still a very similar one to one I've already posted (I thought it might be quite a different one), sorry, however I still don't know how to do it so I would still like help if anyone could give it

tashirosgt
21st April 2006, 05:11 PM
You showed the pvdisplay results for physical volumes. But what do the results for logical volumes say? Things live lvmdiskscan,lvdisplay? I take it you added the physical volume to the logical volume somehow?

JoeyJoJoe
21st April 2006, 05:25 PM
I really don't know what I've done now, however I found a HOWTO which seems to be working, if it does i'll post a link or something so other people can find it.... If it ruins my computer I'll come on on SLAX and let people know not to do it like that. I would also quickly like to thank everyone who helped on both problems i've been having, it was a big help and let me know how to do a lot of stuff and I've learnt some new commands, thanks.Ok, HOWTO's done, its in one of my other questions, called "linux partition full... need more space"