PDA

View Full Version : SCSI tape drive + software



woppa30
20th April 2006, 12:36 PM
I have managed to get hold of a Dell Powervault 110T SCSI tape drive which is a rebadged Quantum DLT7000 machine.
Its attached to an Adapetec SCSI card in a machine which is dual boot with windows and wndows correctly sees and uses the tape drive, to me this means the card, drive and termination are all OK.
I installed FC5 onto a clean hard drive with the tape drive attached, with a tape inside and all switched on. My problem comes when I try and use the tape drive. KDAT won't see it at /dev/st0 I tried Mondo rescue and that also doesn't see it.
I tried looking at /var/log/messages and found this.
Apr 19 19:07:14 woppa kernel: scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 7.0
Apr 19 19:07:14 woppa kernel: <Adaptec AAA-131 Ultra2 RAID adapter>
Apr 19 19:07:14 woppa kernel: aic7890/91: Ultra2 Wide Channel A, SCSI Id=7, 32/253 SCBs
Apr 19 19:07:14 woppa kernel:
Apr 19 19:07:14 woppa kernel: Vendor: QUANTUM Model: DLT7000 Rev: 2150
which tells me the machine can see the drive.
I also checked cat /proc/scsi/scsi and I can see the drive there as well and lsmod shows that the scsi module has loaded.
Does anybody have an idea as to why I can't use this tape drive with either kdat or mondo rescue ??? There isn't an entry for /dev/tape so I am a bit lost really,
Thanks for any help,
Woppa

HaydnH
20th April 2006, 02:25 PM
Have a look at:

http://www.linuxquestions.org/questions/showthread.php?t=372272

woppa30
20th April 2006, 07:41 PM
I tried the first thing that that post suggests and got this....
st 0:0:5:0: Attached scsi tape st0<4>st0: try direct i/o: yes (alignment 512 B)

So I'm now even more confused can a tape drive really be at st0<4>st0 ????

the alst two lines of lsmod show...

sd_mod 16449 0
scsi_mod 124649 5 st,sg,aic7xxx,scsi_transport_spi,sd_mod

woppa30
21st April 2006, 09:48 AM
Just had a quick though about drives for the actual SCSI card. The one I have is this one here...
http://www.adaptec.com/worldwide/support/suppdetail.jsp?sess=no&language=English+US&cat=%2FProduct%2FAAA-131U2&prodkey=AAA-131U2
i.e. an AAA-131U2 I am assuming (and I know that can lead to a whole load of trouble) that the correct SCSI driver is installed. Anybody any idea how I can tell ?? There are downloads for SCO Unixware and Novell along with windows 2000 but nothing for what I would call linux :-(
Thnaks in advance,
Woppa

woppa30
24th April 2006, 08:45 PM
Found the solution so I thought I would post the answer....
Although, as I stated, the SCSI card and DLT tape drive were connected during installation not all the necessary software was installed. DOH!
It turns out I need mn-st.i386 which I installed via yum. Apparently, according to yum ...
"The mt-st package contains the mt and st tape drive management
programs. Mt (for magnetic tape drives) and st (for SCSI tape devices)
can control rewinding, ejecting, skipping files and blocks and more.

Install mt-st if you need a tool to manage tape drives."
Although mondo and kdat were looking at the correct place i.e. /dvev/st0 they could not use the drive because the commands weren't there.
I hope this helps others :-)
Woppa