PDA

View Full Version : Lots of conflicts with yum --update (FC5 x86_64)



pawel.stolowski
19th April 2006, 10:00 PM
I cannot install latest official Fedora updates to KDE (i.e. KDE 3.5.2) and GNOME with yum. Some of the important KDE and GNOME packages on my system are installed in both i386 and x64 versions (this is how they were installed by Anaconda) and now, when it comes to update them, yum throws lots of errors about conflicting files in x64 and their i386 counterparts. And indeed, when I looked into /var/cache/yum/updates/packages at e.g. arts-1.5.2-0.1.fc5.x86_64.rpm and arts-1.5.2-0.1.fc5.i386.rpm I see both have the same files packaged for /usr/bin. What is even more strange, I see the original packages from the FC5 DVD look similar... I wonder how they are supposed to be installed cleanly with yum?? (I know rpm can be forced to do this, but I doubt it is the right way!).

Any ideas on how to overcome this issue?

pawel.stolowski
20th April 2006, 05:41 PM
Problem is solved; it seems i386 updates were not available in x86_64 repo yesterday. Today they are.

dciarnie
20th April 2006, 06:04 PM
Well that's interesting. Why are some i386 packages included in updates but not others, I wonder. I have run into the same problem as you but with libgnome.i386 and librsvg2.i386. Neither of those are in the x86_64 updates tree.

pawel.stolowski
20th April 2006, 06:18 PM
Yeah, that's interesting, it looks like an oversight. I initially thought it was problem with yum and/or packages in the repo (the conflicts) and opened up a bugzilla record for it yesterday, but got a quick reply from one of the FC maintainers who stated the repo was just missing i386 packages.

dciarnie
20th April 2006, 06:29 PM
I also opened up a bugzilla report but I got a reply telling me to enable the i386 updates repo which solved the problem for me.

I took a look at both the core and updates x86_64 trees and saw that arts has both i386 and x86_64 entries in both core and updates while libgnome and librsvg2 only have an x86_64 entry in both core and updates. There is an apparent inconsistency in that some packages have both i386 and x86_64 entries in the x86_64 tree while others do not.

pawel.stolowski
20th April 2006, 06:45 PM
Yes, you're right, GNOME packages are still not in the main repo for x86_64. I just ran an update for them and got similiar errors. After enabling i386 repo everything went fine.