PDA

View Full Version : Cannot change the refresh rate after installing nVidia drivers



matthewcheck
19th April 2006, 10:51 AM
Hi, i installed nVidia drivers for my graphics card GeForce 2 MX400 from livna repo, and after install i cannot change the refresh rate of my monitor (RELISYS 572) to any other value then 70 Hz on 1024x768. If i change the resolution to other values, still there is only one option for refresh rate, and that is 85 Hz on 640x480 and 60 Hz on 800x600. Is there some possibility to change the refresh rate to 85 Hz on 1024x768? I use that refresh rate every day on Windows so i know it works on my monitor. Thanks

ITgeek
24th April 2006, 11:51 PM
Having the exact same problem, have not dug too deep into the forums yet. Will let you know if I turn up anything.

card : Nvidia GeForce 6800 GT
Monitor : NEF MultiSync FE950+

solarisman
25th April 2006, 04:34 AM
haven't tried the livna repo yet, but the nvidia driver package
backs up and replaces the "/etc/X11/xorg.conf file" with its
own version. Open the conf file and scroll down to the
Section "Monitor" and verify your H & V rates are correct.
Then scroll down to the Section "Screen" . For each color
depth listed there is an array of resolutions that can be
displayed. Add the missing resolutions here (quoted),
then log out and back in to restart the X server.

HTH...

matthewcheck
25th April 2006, 04:41 PM
I verified the /etc/X11/xorg.conf file, and everything seem to be allright and stil cannot change the refresh rate. Here is my xorg.conf:


# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "glx"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Relisys RE572"
DisplaySize 270 200
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV11 [GeForce2 MX/MX 400]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

tardis_junkie
25th April 2006, 07:46 PM
Hi,
Add the following to the Device section.

Option "UseEDID" "false"

This stops the driver from auto guessing your refresh rates, you will go back to those specified in the monitor sections.

This worked for me.

steve1961
25th April 2006, 07:59 PM
I had the same problem but the fix in this thread (post 14) fixed it.

http://www.fedoraforum.org/forum/showthread.php?t=101265

First create and insert a modeline, and then edit the screen section as shown.

stanmc
26th April 2006, 12:35 AM
First create and insert a modeline, and then edit the screen section as shown.
Works perfectly. Here is an example of that.

I ran gtf 1152 864 85 giving me this modeline.
ModeLine "1152x864_85.00" 119.7 1152 1224 1352 1552 864 865 868 907 -hsync +vsync
Then I inserted it just above Option "dpms" in the Monitor Section. I also changed the modes in the Section "Screen". I added the _85 to all the modes. Not sure that is necessary, but I am now at 85Hz instead of 75.
--------------------------------------------------------------------------
Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ViewSonic PT775"
DisplaySize 320 240
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
ModeLine "1152x864_85.00" 119.7 1152 1224 1352 1552 864 865 868 907 -hsync +vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
Option "Coolbits" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864_85.00" "1152x768_85.00" "1024x768_85.00" "800x600_85.00" "640x480_85.00"
EndSubSection
EndSection
--------------------------------------------------------------------------

Thanks for the info.

Today 27 April 2006 I played doom3-demo for the first time since I made the above changes. It would not open full screen. I edited the xorg.conf and removed the _85.00 from all of the modes except the first one ("1152x864_85.00"). I now have full screen back in doom3-demo.
Modes "1152x864_85.00" "1152x768" "1024x768" "800x600" "640x480"

matthewcheck
27th April 2006, 05:41 PM
Hey, thanks very much for your help, i really appreciate that. I used gtf 1024 768 85, added that lines to /etc/X11/xorg.conf and did logout-login and i have 85 Hz!! Thanks once again.

But I've got one little problem, and that is that my desktop is maybe 10 px out of screen on monitor. Is there any possibility fix it somewhere? Because if i move the visible part on my monitor, than when i get to windows i have to put it back. Also my monitor is old so i dont have option to set it automaticaly so i have to move it manually and that's why i want to fix it somehow. I hope you understand ... Thanks in advance