PDA

View Full Version : xfs Problem



beardedone
19th April 2006, 09:25 AM
In an attempt to get an X application with its fonts installed on FC5 I modified the xfs config file, and issued a 'service xfs restart' followed by an 'xset fp reset'. This resulted in an "xset: bad font path element" error message. I put the xfs config file back to the way it was and reissued the above 2 commands. I got the same error. After trying to isolate the problem, I went to a different FC4 machine and just issued the above 2 commands without touching the xfs config. I got the same error.

I need help, X applications don't find any fonts on either machine.

Thanks.

cazo
19th April 2006, 10:00 AM
What does '/etc/X11/fs/config' look like? That should be where the 'bad font path element' is. Mine has an entry called 'catalogue' like this:




catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/Type1,
/usr/X11R6/lib/X11/fonts/TTF,
/usr/share/fonts/default/Type1


Make sure all those paths (ignore the ':unscaled" part) exist and are readable & executable (mine are 'drwxr-xr-x' and owned by 'root').

Also, I think the 'xset' command is wrong. From the xset manpage (on an FC4 box):



fp= path,...
The fp= sets the font path to the entries given in the path argument. The entries are inter-
preted by the server, not by the client. Typically they are directory names or font server
names, but the interpretation is server-dependent.

fp default
The default argument causes the font path to be reset to the serverís default.

fp rehash
The rehash argument resets the font path to its current value, causing the server to reread the
font databases in the current font path. This is generally only used when adding new fonts to a
font directory (after running mkfontdir to recreate the font database).

-fp or fp-
The -fp and fp- options remove elements from the current font path. They must be followed by a
comma-separated list of entries.

+fp or fp+
This +fp and fp+ options prepend and append elements to the current font path, respectively.
They must be followed by a comma-separated list of entries.

beardedone
19th April 2006, 05:32 PM
Thanks, I noticed that the reset is not an xset documented option, but it worked? and really messed things up.

I finally fixed my problem by issuing "xset fp+ xxx" for each filename in the fs/config. My guess is that xfs may be hiding information somewhere across restarts.

Thanks