PDA

View Full Version : yum update fails because of libpisock.so.8



g0l3m
18th April 2006, 10:51 AM
Hello all,

When doing a "yum update" I get:
Error: Missing Dependency: libpisock.so.8 is needed by package XXX

Any ideas what I need to "yum install" to get rid of this problem?
I've googled and found that libpisock comes with some opengroupware pilot stuff but pirut seems to think I have these installed already...

Thanx in advance,
g.

Blackrain
18th April 2006, 11:25 AM
I am having the same problem too .....

It said libpisock.so.8 is needed by evolution.

Wayne
18th April 2006, 11:34 AM
I have worked around this. Please see the last 2 messages posted by me in a thread called:

Update depency problem

Bad spelling thrown in for free :-)

Wayne

g0l3m
18th April 2006, 11:46 AM
I've had a look at that thread and I found this quite useful:

"yum --exclude=evolution update"

It will update everything else and leave evolution alone for now...
If you're happy to wait for a fix (which I am), it's definitely a lot simpler than
unistalling stuff and rolling back to previous versions of packages.

cheers for the helps,
g.

Wayne
18th April 2006, 11:51 AM
While that's what I did at first too I was fed up with the previous version of Evolution throwing up an "I've crashed, would you like to restart me or close me" message almost every time I closed it down. I'm hoping this update fixes that, therefore I was more than willing to mess about with development and an older (but apparantly, working) version of pilot-link files.

Cheers

Wayne

htinn
18th April 2006, 11:52 AM
Yay for workarounds. When is the fix?

Wayne
18th April 2006, 11:59 AM
As was mentioned in the other thread by 'Gamx' I think the eventual remedy will be to roll back from pilot-link 0.12 to 0.11 as he/she says it works whereas 0.12 doesn't. I'm just impatient and wanted the updated Evolution. The only palm I have is hot and sweaty but hopefully not hairy :-)

Cheers

Wayne

htinn
18th April 2006, 12:08 PM
Okay, I'll just wait then. :)

Jman
19th April 2006, 05:15 AM
I've heard this update is available now. yum update time.

jhetrick62
19th April 2006, 06:11 AM
I ran it tonight and it wasn't available yet unless maybe my repos are set up different. I followed Stanton Finley for mine. A rpm -ql tells me that libpisock.so.9 is current installed so that's where the issue is. A roll-back of pilot-link probably would work but I'm going to wait until Monday before I roll back.

Jeff

Seve
19th April 2006, 06:38 AM
Hello:
It would appear that all is well again, as I just ran yum -y update and evolution was updated on an i386 and x86_64 box, among other items without any errors. :)


Apr 19 01:32:15 Updated: arts.i386 8:1.5.2-0.1.fc5
Apr 19 01:32:36 Updated: kdelibs.i386 6:3.5.2-0.1.fc5
Apr 19 01:32:48 Updated: kdebase.i386 6:3.5.2-0.2.fc5
Apr 19 01:32:52 Updated: pilot-link.i386 2:0.11.8-12.4.fc5
Apr 19 01:32:59 Updated: kdepim.i386 6:3.5.2-0.1.fc5
Apr 19 01:33:04 Updated: gnome-pilot.i386 2.0.13-7.fc5.5
Apr 19 01:33:08 Updated: kdemultimedia.i386 6:3.5.2-0.1.fc5
Apr 19 01:33:11 Updated: kdebindings.i386 3.5.2-0.1.fc5
Apr 19 01:33:14 Updated: kdesdk.i386 3.5.2-0.1.fc5
Apr 19 01:33:15 Updated: pilot-link-devel.i386 2:0.11.8-12.4.fc5
Apr 19 01:33:20 Updated: kdenetwork.i386 7:3.5.2-0.1.fc5
Apr 19 01:33:23 Updated: kdeutils.i386 6:3.5.2-0.1.fc5
Apr 19 01:33:27 Updated: kdegraphics.i386 7:3.5.2-0.1.fc5
Apr 19 01:33:27 Updated: arts-devel.i386 8:1.5.2-0.1.fc5
Apr 19 01:33:29 Updated: kdelibs-devel.i386 6:3.5.2-0.1.fc5
Apr 19 01:33:30 Updated: kdebase-devel.i386 6:3.5.2-0.2.fc5
Apr 19 01:33:41 Updated: kdevelop.i386 9:3.3.2-0.1.fc5
Apr 19 01:34:02 Updated: evolution.i386 2.6.1-1.fc5.2
Apr 19 01:34:07 Updated: kdeaccessibility.i386 1:3.5.2-0.1.fc5
Apr 19 01:34:08 Updated: kdegraphics-devel.i386 7:3.5.2-0.1.fc5
Apr 19 01:34:09 Updated: psmisc.i386 22.1.03072006cvs-1.1
Apr 19 01:34:09 Updated: kdeutils-devel.i386 6:3.5.2-0.1.fc5
Apr 19 01:34:12 Updated: kdeaddons.i386 3.5.2-0.1.fc5
Apr 19 01:34:14 Updated: kdeartwork.i386 3.5.2-0.1.fc5
Apr 19 01:34:16 Updated: util-linux.i386 2.13-0.20.1
Apr 19 01:34:18 Updated: kdepim-devel.i386 6:3.5.2-0.1.fc5
Seve