PDA

View Full Version : howto repair FC4 if sth wrong in modules?



dt_cry_4_me
18th April 2006, 10:37 AM
I insmod some modules to my FC4, after reboot, some fatal error happens, that's a disaster...
the mount module seems fail because vfat cannot be recognized...
I rmmod the modules immediately, and I delete the vfat line in /etc/fstab, that's useless...


anyway to repair the FC4?
I really don't want to reinstall...


===========boot messenger=========================
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: 8139too device eth0 does not seem to be present,
delaying initialization.
[FAILED]
Starting system logger: [ OK ]
Starting kernel logger: [ OK ]
Starting portmap: [ OK ]
Starting NFS statd: [ OK ]
Starting auditd: [ OK ]
Starting RPC idmapd: FATAL: Module sunrpc not found.
FATAL: Error running install command for sunrpc
Mounting other filesystems: [ OK ]
Starting automount: [ OK ]
Starting acpi daemon: [ OK ]
Starting cups: [ OK ]
Starting sshd: [ OK ]
Starting console mouse services: [ OK ]
Starting IIIMF input server: [ OK ]
Starting crond: [ OK ]
Starting xfs: [ OK ]
Starting anacron: [ OK ]
Starting system message bus: [ OK ]
==============================================

dt_cry_4_me
18th April 2006, 10:38 AM
in addition, i can still log in, but after startx, the mouse doesn't work...

dt_cry_4_me
6th May 2006, 02:49 AM
any suggestion?

how about rebuilding the kernel?

jtester
16th June 2006, 11:11 PM
am getting this error
Starting RPC idmapd: FATAL: Module sunrpc not found.
FATAL: Error running install command for sunrpc
very simular to your one
but I get it on
a uml system.

I have rebuilt it many times and have

Linux:~/uml/linux-2.6.16.18 # grep SUNRPC .config
CONFIG_SUNRPC=y
CONFIG_SUNRPC_GSS=y

Could you please tell me how you solved this

Thanks