PDA

View Full Version : Cannot perform yum update Please Help



scorbel
18th April 2006, 09:48 AM
Hi,

I am trying to perform yum update but get
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package sound-juicer.i386 0:2.14.3-1.fc5.1 set to be updated
---> Package gtk2.i386 0:2.8.17-1.fc5.1 set to be updated
---> Package gtksourceview.i386 0:1.6.1-1.fc5.1 set to be updated
---> Package gnome-user-docs.noarch 0:2.14.2-1.fc5.1 set to be updated
---> Package netpbm-devel.i386 0:10.33-1.fc5 set to be updated
---> Package glib2.i386 0:2.10.2-1.fc5.1 set to be updated
---> Package yelp.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gedit.i386 1:2.14.2-1.fc5.1 set to be updated
---> Package nautilus-cd-burner.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnome-applets.i386 1:2.14.1-1.fc5.1 set to be updated
---> Package glib2-devel.i386 0:2.10.2-1.fc5.1 set to be updated
---> Package libgtop2-devel.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package libbeagle.i386 0:0.2.4-1.fc5.1 set to be updated
---> Package beagle.i386 0:0.2.4-1.fc5.1 set to be updated
---> Package gnome-desktop-devel.i386 0:2.14.1.1-1.fc5.1 set to be updated
---> Package netpbm-progs.i386 0:10.33-1.fc5 set to be updated
---> Package libgtop2.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnome-panel-devel.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnome-utils.i386 1:2.14.0-4 set to be updated
---> Package eel2.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnome-terminal.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package netpbm.i386 0:10.33-1.fc5 set to be updated
---> Package bind.i386 30:9.3.2-16.FC5 set to be updated
---> Package libgnomeui.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package nautilus.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package pango.i386 0:1.12.1-1.fc5.1 set to be updated
---> Package control-center.i386 1:2.14.1-1.fc5.2 set to be updated
---> Package bind-config.i386 30:9.3.2-16.FC5 set to be updated
---> Package evolution-data-server.i386 0:1.6.1-1.fc5.2 set to be updated
---> Package librsvg2.i386 0:2.14.3-1.fc5.1 set to be updated
---> Package pango-devel.i386 0:1.12.1-1.fc5.1 set to be updated
---> Package gnome-panel.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnome-system-monitor.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnome-screensaver.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package eog.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnome-desktop.i386 0:2.14.1.1-1.fc5.1 set to be updated
---> Package gtk-doc.noarch 0:1.6-1.fc5.1 set to be updated
---> Package evolution.i386 0:2.6.1-1.fc5.2 set to be updated
---> Package libsoup.i386 0:2.2.92-1.fc5.1 set to be updated
---> Package eel2-devel.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package libgnomeui-devel.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package gnopernicus.i386 0:1.0.4-1.fc5.1 set to be updated
---> Package at-spi.i386 0:1.7.7-1.fc5.2 set to be updated
---> Package atk.i386 0:1.11.4-1.fc5.1 set to be updated
---> Package gtkhtml3.i386 0:3.10.1-1.fc5.1 set to be updated
---> Package libgnome.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package bind-libs.i386 30:9.3.2-16.FC5 set to be updated
---> Package atk-devel.i386 0:1.11.4-1.fc5.1 set to be updated
---> Package librsvg2-devel.i386 0:2.14.3-1.fc5.1 set to be updated
---> Package file-roller.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package libwnck.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package evolution-data-server-devel.i386 0:1.6.1-1.fc5.2 set to be updated
---> Package at-spi-devel.i386 0:1.7.7-1.fc5.2 set to be updated
---> Package bind-utils.i386 30:9.3.2-16.FC5 set to be updated
---> Package gtk2-devel.i386 0:2.8.17-1.fc5.1 set to be updated
---> Package gnome-session.i386 0:2.14.1-1.fc5.1 set to be updated
---> Package metacity.i386 0:2.14.3-1.fc5.1 set to be updated
---> Package libgnome-devel.i386 0:2.14.1-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libpisock.so.8 for package: evolution
--> Finished Dependency Resolution
Error: Missing Dependency: libpisock.so.8 is needed by package evolution

though I have libpisock.so.9 which is a higher version

Please advise
Jo

bob
18th April 2006, 01:29 PM
Work around the immediate problem with 'yum --exclude evolution update'. Afterwards, you can try to 'find' the older version or force the update (see 'man yum') but be prepared if it breaks.

Wayne
18th April 2006, 01:39 PM
Being the impatient type, I worked around the problem after upgrading without Evolution. Results of my madness can be found in a badly spelled thread called:

Update depency problem

It was early and I hadn't had sufficient quantities of caffeine, now it's getting late and I'm a couple of sips out of beer! Life ain't fair :-(

Wayne

bob
18th April 2006, 01:49 PM
That link is here: http://forums.fedoraforum.org/showthread.php?t=105416 - Also, it's beer drinking time in Tokyo? Well, close enough to Eastern Standard Time for me!!!!

Wayne
18th April 2006, 01:53 PM
A few minutes to 10pm and I'm out of brew :-(

Cheers!

Wayne

u-noneinc-s
18th April 2006, 07:46 PM
No more Sapporo?

Wayne
18th April 2006, 11:22 PM
I was drinking the new recipe Suntory :-) It's a litle more hoppy than the old version!

Now morning, need coffee...

Wayne