View Full Version : Sound Fustration

16th April 2006, 12:00 AM
The other night i thought time to upgrade but because i had everything working the way i wanted in fedora core 4 i thought i would just update what i had , so via yum extender i updated everything i wanted to update. Upon a reboot though i now have no soundcard. It was working fine before but now its stopped working, i have tried everything i know to get it back up and running but to no avail , i have updated alsa but that did not seem to help , upon selecting sound card detection i just get no sound card detected, after booting up and logging into kde 3.5 i get

device /dev/dsp can't be opened (No such file or directory)

will use null sound output

would this have been there before but has now gone, i am lost could anybody point me in the right direction as to what to do.

I also grabbed alsaconf and tried to manually do a config but to no avail.

This is really fustrating me, although sound is not essential it would be good to have it.

16th April 2006, 12:12 AM
Need more info. What sound card brand and model is it.
What modules are loaded? type ' lsmod ' to list modules.
Is the soundcard module loaded?
Did you upgrade the kernel? Which one? What did you have before?
Can you boot with the older kernel? This may get sound going.
If this works then the new kernel either does not have the soundcard module compiled or is bad.


16th April 2006, 01:00 AM
sorry my mistake i should have provided more info.

The machine is an old one , its an compaq desktop ens/p800 small formfactor, i got it about 2 months ago to run my irc server, it runs a p3 1000mhz and has sound built in , from what i have been able to find it just says ac97 built in sound.

Yes i upgraded the kernel from 2.6.11-1.1369_fc4 to 2.6.16-1.2069 , all this was done via the yum extender.

I have tried booting the other kernel but i am just met with the same results.

modules running are as follows

Module Size Used by
parport_pc 27181 1
lp 12929 0
parport 35977 2 parport_pc,lp
autofs4 19397 2
i2c_dev 9185 0
i2c_core 21697 1 i2c_dev
rfcomm 36821 0
l2cap 24641 5 rfcomm
bluetooth 47397 4 rfcomm,l2cap
sunrpc 145893 1
iptable_filter 3137 0
ip_tables 12313 1 iptable_filter
x_tables 12741 1 ip_tables
video 15173 0
button 6609 0
battery 9413 0
ac 4933 0
ipv6 249089 16
uhci_hcd 31825 0
hw_random 5977 0
e100 35013 0
8139too 26561 0
mii 5697 2 e100,8139too
floppy 63869 0
dm_snapshot 16749 0
dm_zero 2113 0
dm_mirror 21237 0
ext3 128329 3
jbd 56789 1 ext3
dm_mod 53333 6 dm_snapshot,dm_zero,dm_mirror

16th April 2006, 03:09 PM
I don't see any sound modules loaded that I know of. After a fresh reboot run the command ' dmesg ' and see if there are any errors listed.
Whats in your /etc/modprobe.conf?
What does the command ' lspci ' say about the sound card?


16th April 2006, 08:47 PM
well i am geting lost now , dmesg does not report any error's but then again its not reporting any sound card either. Looks like its getting everything else but.

modprobe is as follows.

alias eth1 e100
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller uhci-hcd
alias eth0 8139too
alias dev29012 8139too

and lspci does not mention it either

00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82815 CGC [Chipset Graphics Controller] (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 01)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 01)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 01)
02:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller (rev 01)
02:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

I do not know why everything was working fine then just a kernel upgrade throws the whole sound card out the window lol.

16th April 2006, 10:29 PM
there is a problem with some intel cards and the new 2.6.16 kernel. It is a pain too. I have a Dell here at work, come to find the system booted, but the sound was toast. After googling I found that my driver (SPxxx or something like that) doesn't play well with alsa. But there is hope.

do a google search for
intel site:alsa-project.org

And you will find an aritcle about installing alsa-1.0.11rc4 or something of that sort. Apparently redhat uses 1.0.11rc2 (rpm -qa | grep alsa) and those libraries don't offer support for some intel cards. If you follow the guide, download the newest 1.0.11rc3 or 4 (4 is most recent, then one I installed) you should be able to get sound working (like I did). But that is only if your sound card is recognized with that funny driver and is an intel mobo. Google around (it is your friend) and can help you find solutions. Better yet - maybe you can find a 1.0.11rc4 rpm somewhere??

16th April 2006, 11:55 PM
cheers for the info will check it out and see if i can get things working, i am still tossing up on maybe just doing a clean install of fedora but going to 5 , have not decied yet. But will be leaving doing a kernel upgrade alone this time.

18th April 2006, 09:46 AM
Hello all,

I am having a similar problem in that I don't have sound on my Asus P4P800 mobo. I installed the updated alsa software, but still no sound. :( Does anyone have any suggestions for me?


18th April 2006, 07:00 PM
I did a fresh install to FC5 after probs with upgrade. My mobo is Asus A8V-mx with AMD Athlon 64 CPU. Manual shows Realtek ALC653 as sound chip. lsmod shows via82xx modules, lspci sees"Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 70)
". Apps produce a short burst of sound then die. (CD player seems to work so prob is pcm). I downloaded source from Realtek for alsa-driver but the compile craps complaining about line 460 in pci.h. I am using kernel 2.6.16-1-2080_FC5
My sense is that the pcm code is the prob. I have tried forcing 'NONBLOCKING" option to no avail. Any suggestions welcome

18th April 2006, 08:08 PM
Appears to be a corny layout on the MOBO, Why it works on Windows but not on Linux a mystery. I have it working after routing speaker out to front of the box /
Go figure ? Apologies for suggesting FC5 is flawed. Now on to the scanner..

18th April 2006, 08:19 PM
I recant. The CD sound is much better PCM still broken. TVTIMe, XINE, etc all short burst then die. Same for RADIO

19th April 2006, 12:33 AM
The AC97 should wok. U will get it working.
Try a "yum upgrade" ... that solved my last sound problem.

23rd April 2006, 10:56 AM
If u have updated everything and still no sound, hmm ... then i have no idea now.

AC97 should work out of the box, and is working out of the box. Everytime i had trouble, an update solved everything. Troubleshooting sound yourself is a good idea, but u need to be a linux expert, and need to be familiar with dmesg and other console command outputs.

What u can try: put a PCI soundcard in and test it,

Dont use private messages, use the forum threads.

23rd April 2006, 09:36 PM
Not sure if I qualify as a linux expert, having used for only 11 years (slackware, suse, knoppix, Red Hat and all flavours of Fedora) :)

Repeated updates/upgrades have done nothing. alsamixergui identifies card but has prob with ac97. dmesg show no clue nor does cat /var/log/meassages

i would cheerfully compile the driver if it did not crap on pci.h as noted before.

23rd April 2006, 10:06 PM
On the assumption that there are experts out there who like to read log files I attach scsound.log for my system
after config failed to produce sound.