PDA

View Full Version : Tiny Nvidia error :)



bigboss2200
11th April 2006, 09:03 PM
i tried all what i can do to make my nvidia work but with no results :( .. i also tried the How-To tutorial posted by "Firewire" and just faild :(..

and in addition, i cant use "yum".. coz im using a dial-up modem.. and i couldnt make the FC5 recognize it (i succeeded in FC4, but still working on 5"..

anyway.. I have downloaded and installed the following pakages:

kernel-2.6.16-1.2080_FC5.i686
kernel-devel-2.6.16-1.2080_FC5.i686

then downloaded the Nvidia driver: "NVIDIA-Linux-x86-1.0-8756-pkg1.run"..

i went throw the terminal, typed "init 3" and installed the driver.. it went all ok.. and it did install.. and it was recognized after typing "modprobe nvidia".. BUT when i turned back to the X - server, it just couldnt load.. it gave me an error says that the X-server couldnt be loaded..


(==) log file: "\var\log\Xorg.0.log", Time Tue Apr 11 23:43:36 2006
(EE) Faild to load module "glx" (a required submodule could not be load)
(EE) Faild to load module "nvidia" (module does not exist, 0)
(EE) No driver available


so, i just accepted to re-write the "Xorg.conf" file.. and it went back to the "nv" driver..

what should i do..????!?!?!?

boyaci
12th April 2006, 03:53 AM
In your /etc/X11/xorg.conf file, under "Files" section, add the following lines related to module path, it can go after the section "ServerLayout". because nvidia dirver is still in the X11R6 directory, not the new xorg directory.

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
ModulePath "/usr/X11R6/lib/modules"
ModulePath "/usr/X11R6/lib/modules/extensions"
ModulePath "/usr/lib/xorg/modules"
FontPath "unix/:7100"
EndSection

bigboss2200
12th April 2006, 06:57 PM
Thanks for ur reply :)

actually, ive downloaded "kmod-nvidia-1.0.8756-1.2.6.16_1.2080_FC5.i686.rpm" and "xorg-x11-drv-nvidia-1.0.8756-1.lvn5.i386.rpm".. installed them, then installed the nvidia driver and everything went OK :D

but the frame rate average is very low.. "about 2045".. what should i do to make it faster??

boyaci
12th April 2006, 07:17 PM
with nvidia-settings tool, try unchecking the sync to vblank and page flipping options under opengl settings. this may increase the fps values but will eventually introduce tearing artifacts - I never like going beyond my computer's vertical refresh rate. Also check the xorg.conf file, Xorg searches the modules in the order given in the paths in section "FIles". If the nvidia related path is not before the default xorg path, you may try changing that order and restarting x. (with something like gdm-restart).

wally_666
12th April 2006, 10:38 PM
On Fedora Core 5 there seems to be a performance issue with the v7 Xorg modular server. Its fixed in "development". See this thread for the details: http://forums.fedoraforum.org/forum/showthread.php?t=103211

--wally.

bigboss2200
14th April 2006, 02:35 PM
thanks guyz for the replies.. i will check all ur suggestions and try them..