View Full Version : Dazed & Confused Newbie: Ndiswrapper FC5

pablo paul
11th April 2006, 12:13 AM
Hi Guy's,

I'm a having real trouble getting ndiswrapper to compile. I've googled myself to death and just can't figure out what to do next (or what i've done already).

I downloaded the latest source for the ndiswrapper website and followed the instructions in the wiki. when i did the make i got a few errors one being the 4K stack issue and also an error that it couldn't find the source kernel.

make -C driver
make[1]: Entering directory `/root/ndiswrapper/ndiswrapper-1.12/driver'
Can't find kernel build files in /lib/modules/2.6.16-1.2080_FC5.stk16/build;
give the path to kernel build directory with
KBUILD=<path> argument to make
make[1]: *** [prereq_check] Error 1
make[1]: Leaving directory `/root/ndiswrapper/ndiswrapper-1.12/driver'
make: *** [all] Error 2

I downloaded a 16k stack kernel (and source) and installed them. The Kernel warnings went away but it still wouldn't make. when i checked /lib/modules/2.6.16-1.2080_FC5.stk16/build the link was broken. So i downloaded the kernel source (i think from kernel.org!! i couldn't figure out where the original source went) and put it here /usr/src/linux- and then linked the two. I did a make and it failed again with the same error.

I'm completely lost and thinking about throwing the laptop against the wall. ANY help for a completely confused newbie would be appreciated.

11th April 2006, 01:07 AM
That source will not work for the precompiled kernel you have downloaded. Goto the site you got your precompiled kernel from and get the matching version number called kernel -devel-2.6.16-1.2080_FC5.stk16. The source kernel is not the same as 2.6.16-1.2080_FC5.stk16 because this one has been patched and other things applied. is the orginal default kerenl used to build 2.6.16-1.2080_FC5.stk16 but with patches applied. So look for kernel-devel.*.rpm.


pablo paul
11th April 2006, 12:19 PM
Thanks for the reply. I did download the source 2.6.16-1.2080_FC5.stk16.src.rpm. but it didn't appear in /usr/src as i expected. How can i find out where the rpm installed? i assume i can then just link to /lib/modules/2.6.16-1.2080_FC5.stk16/build and then do the make and it should compile? (i'm at work at the moment so may have written the paths slightly wrong)

Thanks for all your help it is greatly appreciated.

11th April 2006, 09:48 PM
You can't use the files in the /lib/modules because they are compiled software. It requires the source to get the needed info.
Use the command ' rpm -qlp name_ofrpm.rpm ' to show what files are in it and where they will be installed.


pablo paul
12th April 2006, 09:29 PM
I managed to get ndiswrapper to build and managed to install the driver and i know it's working even though the light on the card is off
when i run iwlist wlan0 scan i get a list of all the access points in my area.

So i know the card is working but i now have a new problem when i go to networking and try to add wlan0 to the list NDISWRAPPER(wlan0) doesn't appear. I used ndiswrapper -m so i thought wlan0 whould show up in the device list. Any ideas??