PDA

View Full Version : No Sound Powerbook g3 Lombard


johnficca
7th April 2006, 05:50 PM
Hi I'm like of new to Linux/fedora so I hope this doesnít sound dumb Iím running a powerbook g3 Lombard and I just installed fedora core 5 everything works but the sound and I keep getting this error message, Error while initializing the sound driver: (no such file or directory) the sound sever will continue, using the null out put. And I was just wondering if anyone could please help me I would like to have sound :)

johnficca
14th April 2006, 04:36 PM
so I guess there is just no way to have sound ?

ruko098
7th May 2006, 02:38 PM
i have the same prob on my iBook g3 600, but i'm running fc4... I know the speakers aren't bad because I still hear the startup chime when I turn on my computer. And sound works fine w/ headphones. wtf??

gborglomb
8th May 2006, 05:52 AM
I found a way to make sound work on my Lombard running FC5.

Open a terminal window as root.
Type: modprobe snd-powermac

You should hear a click from the speakers. Sound should now be working, however you still need to run System->Administration->Soundcard Detection and play the test sound in order for the red-x to go away on the speaker icon in the corner.

You can put the (modeprobe snd-powermac) command in the rc.local file so it will come up automatically. But so far, I still have to run Soundcard Detection to make it work perfectly. rc.local is in the /etc/rc.d directory.

Not sure why this doesn't work in the modprobe.conf file. It should.

The sound working the headphones and not the speaker is a different problem. Open the Settings Tab of the Mixer Applet and turn on Check [x] External Amplifier.

Looks like there is a patch from alsa to fix the problem, search the forums for alsa-1.0.11rc3cvs.patch.bz2 there is link to download it.

ruko098
16th May 2006, 02:01 AM
Sounds like good advice! I don't know about you guys, but my 22 mo old son walked up to my iBook and mashed a few keys. Next thing I know, I hear sound, and ever since, the speakers have worked! weird...