PDA

View Full Version : Any expert (scientific) there: Scigraphica Issues



mshokrey
5th April 2006, 10:59 PM
Guys,

I need your help concerning some issues whiel compiling Scigraphica?

After comilation and installation of libscigraphica successfully, I started to compile and install scigraphica it self, but unfortunately I got the following error

/usr/bin/ld: cannot find -lscigraphica-2.1
collect2: ld returned 1 exit status
make[2]: *** [scigraphica] Error 1


Please help me to solve this issue, Also if any one of you can make scigraphica rpms for fedora core 5, it will be a fascinating thing.

I hope anyone can solve this issue for me .

Waiting for your repllys

Jman
6th April 2006, 06:50 AM
Building packages isn't too tricky. A draft of the buildind packages guide so far. (http://fedoraproject.org/wiki/Docs/Drafts/BuildingPackagesGuide)

mshokrey
6th April 2006, 08:40 AM
Building packages isn't too tricky. A draft of the buildind packages guide so far. (http://fedoraproject.org/wiki/Docs/Drafts/BuildingPackagesGuide)
Yes, itsn't too tricky.

But as per my first messege I've tried to build it from the src rpm, but unfortunately I got a messege said build error " copy right GPL"

So, that I hope any one help me building it. If it isn't too tricky for me as a beginner user, then for sure it will be nothing for any one of you (expert) guys. That's why I am asking your help.

I hope you understand what I mean?

Jman
7th April 2006, 02:53 AM
Sorry I don't know what you mean by that.

Please link to a downloadable URL of what you are trying to install and the command s you're using so we can duplicate it.

mshokrey
7th April 2006, 07:09 AM
Sorry I don't know what you mean by that.

Please link to a downloadable URL of what you are trying to install and the command s you're using so we can duplicate it.
Sounds good to pay attention for my post again. I really appreciate that.
This is the link for the site : http://scigraphica.sourceforge.net/
And these are the files I'm trying to install
a- http://kent.dl.sourceforge.net/sourceforge/scigraphica/libscigraphica-2.1.0.tar.gz
b- http://kent.dl.sourceforge.net/sourceforge/scigraphica/scigraphica-2.1.0.tar.gz

In order to install these files. I've done the following steps:-
1- I've installed GTKextra and numpy using Yum.
2- I've " configured, make, make install" for libscigraphica 2.1 without any problems.
3- I've configured scigraphica 2.1 without any problem also.
4- Unfortunately, when I tried to run make. It gives the above mentioned error.

Any more clarifications or needed links concerning this issue please ask for them in you reply to this post.

I really appreciate your attention.

Waiting for your reply

Seehund
7th April 2006, 04:57 PM
I gave this a go, and this is what I did:

1. yum install gtk+extra gtk+extra-devel numpy
2. Download and unarchive libscigraphica-2.1.1.tar.gz and scigraphica-2.1.0.tar.gz
3. cd libscigraphica-2.1.1; ./configure --prefix=/usr; make; su; make install
4. cd scigraphica-2.1.0; ./configure --prefix=/usr; make; su; make install
Voilá! At least it runs, I haven't tested it any further.

mshokrey
8th April 2006, 08:52 AM
I gave this a go, and this is what I did:

1. yum install gtk+extra gtk+extra-devel numpy
2. Download and unarchive libscigraphica-2.1.1.tar.gz and scigraphica-2.1.0.tar.gz
3. cd libscigraphica-2.1.1; ./configure --prefix=/usr; make; su; make install
4. cd scigraphica-2.1.0; ./configure --prefix=/usr; make; su; make install
Voilá! At least it runs, I haven't tested it any further.
Unfortunately, I ran into trouble agian.

When I tried to make libscigrahica I got the following error

"In file included from ../../scigraphica/sg.h:44,
from sg_dialog.c:21:
../../scigraphica/sg_python.h:35:25: error: arrayobject.h: No such file or directory
sg_dialog.c: In function 'run_unmap_handler':
sg_dialog.c:48: warning: unused parameter 'dialog'
sg_dialog.c: In function 'run_delete_handler':
sg_dialog.c:56: warning: unused parameter 'dialog'
sg_dialog.c:57: warning: unused parameter 'event'
sg_dialog.c: In function 'run_destroy_handler':
sg_dialog.c:68: warning: unused parameter 'dialog'
sg_dialog.c: In function 'button_clicked_yes':
sg_dialog.c:248: warning: unused parameter 'button'
sg_dialog.c: In function 'button_clicked_no':
sg_dialog.c:256: warning: unused parameter 'button'
sg_dialog.c: In function 'button_clicked_cancel':
sg_dialog.c:264: warning: unused parameter 'button'
sg_dialog.c: In function 'button_clicked_apply':
sg_dialog.c:272: warning: unused parameter 'button'
sg_dialog.c: In function 'button_clicked_ok':
sg_dialog.c:280: warning: unused parameter 'button'
make[3]: *** [sg_dialog.lo] Error 1
make[3]: Leaving directory `/home/mshokrey/data/Scigraphica/libscigraphica-2.1.1/scigraphica/widgets'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/mshokrey/data/Scigraphica/libscigraphica-2.1.1/scigraphica'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mshokrey/data/Scigraphica/libscigraphica-2.1.1'
make: *** [all] Error 2
"

However I never get it before while "make and make install"

I searched for arrayobject.h I found two copies under /usr/lib/python-2.4. one of them under numpy and the other under gnumeric. Is this duplication is causing the trouble"? as when I make libscigraphica before, gnumeric wasn't installed"
However I removed gnumeric and tried to make it agian but no way!!!!!!

I think It will be better for any one of you to help in makeing an Fedora Core 5 rpm for this software, because this help us to bypass all these complications. I hope you consider this issue. I appreciate your replies.

Seehund
8th April 2006, 12:50 PM
I've got arrayobject.h in:
/usr/include/python2.4/Numeric/arrayobject.h
/usr/lib/python2.4/site-packages/numpy/core/include/numpy/arrayobject.h

The first one belongs to python-numeric-23.7-2.2.1, the second to numpy-0.9.5-1.fc5.

mshokrey
8th April 2006, 08:57 PM
I've got arrayobject.h in:
/usr/include/python2.4/Numeric/arrayobject.h
/usr/lib/python2.4/site-packages/numpy/core/include/numpy/arrayobject.h

The first one belongs to python-numeric-23.7-2.2.1, the second to numpy-0.9.5-1.fc5.
I already have both of those files, but the "make" give me that the above mentioned error. If you read my first post, you will find me pointing out that I've succeeded in "configure ; make ; make install" for libscigraphica. The problem is that I can't do it again using --prefix=/usr . So I think the best way is to have a rpm for fedora core 5, this will help much more than the different errors produced while compiling. If you have further adivce in order to handle this please tell me.

bryancole
9th April 2006, 11:53 AM
Scigraphica is a somewhat dead project, from the OSS point of view. There's almost zero activity on it's mailing lists, meaning there are few people out there able to help you.

For another Origin clone, try
http://soft.proindependent.com/qtiplot.html
or
http://home.gna.org/veusz/

mshokrey
10th April 2006, 10:53 AM
Scigraphica is a somewhat dead project, from the OSS point of view. There's almost zero activity on it's mailing lists, meaning there are few people out there able to help you.

For another Origin clone, try
http://soft.proindependent.com/qtiplot.html
or
http://home.gna.org/veusz/

I 've already installed Grace. It is performing what was needed form Scigraphica.

mshokrey
11th April 2006, 07:48 AM
Scigraphica is a somewhat dead project, from the OSS point of view. There's almost zero activity on it's mailing lists, meaning there are few people out there able to help you.

For another Origin clone, try
http://soft.proindependent.com/qtiplot.html
or
http://home.gna.org/veusz/
Well, Do you know how to insatall Qtiplot form the source files.

" 4) modify the 'qtiplot/qtiplot.pro' file in order to set the INCLUDEPATH and LIBS variables to point to the location of the GSL and QwtPlot3D libraries on your system (header files and dynamic lib files)."

I don't know how to modify qtiplot.pro to set the INCLUDEPATH and LIBS ....etc.

You have any idea about that?

bryancole
20th April 2006, 07:15 PM
I'm no Qt expert but see

http://doc.trolltech.com/3.0/qmake-manual-4.html