PDA

View Full Version : SCIM can't be triggerd for most programs?



fedoradebut
5th April 2006, 06:59 PM
Hello guys,

I am using fedora5, gnome English environment with Chinese language support, I want to do some Chinese input, but can't trigger scim on firefox, thunderbird, xterm, text editor and almost all the programs, there is only one exception - just now I noticed I can input Chinese in PSI(http://psi-im.org/),

I have set these,

mkdir ~/.xinput.d
ln -s /etc/X11/xinit/xinput.d/scim ~/.xinput.d/default

and these,
export LC_CTYPE="en_US.UTF-8"
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim

and also I have tried these after finding the above did not work,

export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=xim
export QT_IM_MODULE=xim

NO effect anyway,

the following are some setting of currently, please have a look,

[root] set | egrep -i "xim|scim|lan"
GDM_LANG=en_US.UTF-8
GTK_IM_MODULE=scim
LANG=en_US.UTF-8
QT_IM_MODULE=xim
XMODIFIERS=@im=SCIM

[root]# ls -al .xinput.d/
total 20
drwxr-xr-x 2 root root 4096 Apr 4 16:10 .
drwxr-x--- 27 root root 4096 Apr 5 10:58 ..
lrwxrwxrwx 1 root root 28 Apr 4 16:10 default -> /etc/X11/xinit/xinput.d/scim

[root]# scim -l
Smart Common Input Method 1.4.4

Available FrontEnd module:
socket
x11

Available Config module:
simple
socket
dummy

Available IMEngine module:
chewing
m17n
pinyin
rawcode
socket
table

[root]# cat /etc/X11/xinit/xinput.d/scim
XIM=SCIM
XIM_PROGRAM=scim
XIM_ARGS="-d"
GTK_IM_MODULE=scim

SCIM_QTIMM_XINPUT=/etc/X11/xinit/xinput.d/scim-qtimm
[ -r "${SCIM_QTIMM_XINPUT}" ] && . ${SCIM_QTIMM_XINPUT}
unset SCIM_QTIMM_XINPUT
# override with xim for now
QT_IM_MODULE=xim

So what should I do next?