PDA

View Full Version : Disk Cache @ 67% of memory- Is this normal?



Xtremegene
5th April 2006, 10:58 AM
I apologize if I am being overly nervous, but I've perused and searched the boards here and have not found a definite answer.

I recently just installed FC5 and updated to build 2080 (to install livna ATI drivers) and they worked out fine. I also installed and played around with KDE since I have never really used it before. So far, it looks good to me. However, after a few minutes of usage, I'm noticing that my free physical memory is very low (~20 MB). This is after doing various things, but mainly surfing with Firefox. My disk cache is in the 60%+ (650MB +) usage right now.

Should I be worried that so much of my memory is being cached, while only 22% (right now) is actually being for application data? The only reason I noticed a slowdown was in viewing a website in Firefox, though the slowdown disappears in Konqueror. Is it the OS or Firefox being naughty? For reference, I have 1GB of memory. The rest of my system specs. are in my signature. The memory usage data was viewed from KInfoCenter.

Thank you in advance for any input.

tomcat
5th April 2006, 11:14 AM
That is quite a lot of memory usage, imho. I hope that there ain't a memory leak somewhere. On my box, which runs Gnome and which also has 1GB or Ram, I rarely need more than 300 MB Ram, even with multiple apps like OOo, Firefox and Evolution running. Open a terminal and run "top", it will show you where your ressources go. If there is something unusual, report back, so others can check if they can reproduce your problem. If yes, it must be a memory leak/bug in one package, if not, we might have to search for the reasong why your Ram consumption is that high.

darkprok
5th April 2006, 01:18 PM
> Disk Cache @ 67% of memory- Is this normal?
yes.

Xtremegene
5th April 2006, 11:25 PM
Thanks for the replies, guys.

I didn't see anything out of the ordinary when I ran top earlier, but then again I didn't know exactly what to look for. When I was randomly surfing, it seems that an extension I was using for Firefox, ForecastFox 0.8.5, had a memory leak. I've since uninstalled it and my cache seems to be more conservative in its girth (@ 31% now after 20 minutes of surfing). Unfortunately, the website that I had the slowdown at earlier still is acting choppy, but I guess that has to deal with Firefox's rendering of it and can't be bothered with (for now).