PDA

View Full Version : fstab config help -- mount ext3 partition rw for all users?



krazyshane
5th April 2006, 04:31 AM
Okay, well, i have successfully partitioned and formatted my 2nd HD, and I can mount it.

I have added the following line to my fstab:

/dev/hdb1 /media/hd2 ext3 auto,rw,exec,user 0 0

My question is, how can I mount it so that it is rwx for ALL users and not just the root? Or is this simply a chmod change once?

Shane

krazyshane
5th April 2006, 04:33 AM
Hmm seems like running
#chmod 777 /media/hd2

has fixed the problem. One other question then. How can I configure it so that it shows up under the My Computer icon?

Shane

Christy
5th April 2006, 04:35 AM
defaults,user,umask=0000 0 0 works for vfat. I'm not sure about ext3

edit: this was for your first post

krazyshane
5th April 2006, 04:44 AM
defaults,user,umask=0000 0 0 works for vfat. I'm not sure about ext3

edit: this was for your first post

Umask isnt an option for ext3 :p Thanks tho. I got that part by using chmod.

Any idea on how to add it to the "Computer" section off the desktop?

Shane

Christy
5th April 2006, 04:48 AM
Umask isnt an option for ext3 :p Thanks tho. I got that part by using chmod.

Any idea on how to add it to the "Computer" section off the desktop?

Shane


Was just a guess, I've never had to mount an ext3 partition.

Christy
5th April 2006, 04:57 AM
Check this out (http://gnomesupport.org/forums/viewtopic.php?t=6111&sid=b4c90c19ef6efefda584c88b794a1548) . It might help with the computer issue

ItsTheSource
5th April 2006, 06:34 AM
there is a better alternative to giving the entire world access to the folder...change the ownership of the /media/hd2 folder to your normal username by running

chown <username> <directory> and keep the permissions @ 755

Seehund
5th April 2006, 01:23 PM
Check this out (http://gnomesupport.org/forums/viewtopic.php?t=6111&sid=b4c90c19ef6efefda584c88b794a1548) . It might help with the computer issue

It won't help in FC5.
This (http://forums.fedoraforum.org/forum/showpost.php?p=485142&postcount=4) will.