PDA

View Full Version : Install java 1.4.2.11 sdk on Fedora 5



yinglcs
5th April 2006, 04:12 AM
Hi,

I try to download java 1.4.2.11 sdk on fedora 5, from here:
http://java.sun.com/j2se/1.4.2/download.html
But it always fails, I have tried download the file 3 files from 2 different networks, but I still have the same error. I appreciate if you can help.

Thank you.

Here is the log:
Do you agree to the above license terms? [yes or no]
yes
Unpacking...
tail: cannot open `+511' for reading: No such file or directory
Checksumming...
1
The download file appears to be corrupted. Please refer
to the Troubleshooting section of the Installation
Instructions on the download page for more information.
Please do not attempt to install this archive file.

Spoon!
5th April 2006, 05:07 AM
You should install Java 1.5 using these instructions (http://www.fedorafaq.org/#java) instead.

yinglcs
5th April 2006, 05:59 AM
I need java 1.4 for development reason.

Thanks for any tips.

ItsTheSource
5th April 2006, 06:11 AM
ensure that before you execute the bin file that you run
chmod +x *.bin
in the same directory as the installer

yinglcs
5th April 2006, 07:03 PM
Yes, I did that. But still the same problem.
I try the rpm as well, still have the same problem.

cwcoleman
26th May 2006, 04:33 AM
I use java 1.5 with netbeans using Redhat ES 4. I have servlets in development
but not live at this point. It's an educational server.

The fedora install is tricky since fedora 5 come pre-configured with java.
I've installed 1.5 on a Fedora box, but I had to kill a symlink. I just can't recall
what link I killed. I use " jdk-1_5_0_03-nb-4_1-linux.bin " and
install using a ./*bin after a chmod +x *.bin.

It works great. I just can't recall the symlink I killed to get things to work with fedora.
I'm setting up a test server right now using FC5 so I probably will figure things out again.

If you've solved the problem let me know.

cwc

rage21st
7th June 2006, 10:03 AM
I have the same problem! Anyone can solve it!?

aliber4079
7th June 2006, 01:04 PM
maybe run it by typing "sh jdk.bin" ?