PDA

View Full Version : can't see my xp drive when logging in fc5



ramimgh
4th April 2006, 06:32 AM
i just installed fc5 on a slave 8 GB hard drive, the master is 80 GB with win XP int, when i log into linux, it doesn't recognize any other drives except the root, which has only 1 GB free space on it, can anyone help me with that because i need some space for many other softwares and stuff, thanks.

JohnVV
4th April 2006, 08:21 AM
hi you will nead to install the ntfs kernl driver

see this help page
http://stanton-finley.net/fedora_core_5_installation_notes.html#NTFS

ramimgh
4th April 2006, 05:41 PM
but my system file partition is fat32, does that still work.

MetalMan
4th April 2006, 07:45 PM
If it's FAT32, Linux should recognize it. However, if the FC5 installer did not add a mount line for it, you're going to have to edit your /etc/fstab file (don't forget to do it as root).

ramimgh
5th April 2006, 01:03 AM
i don't get, , i connected the fedora drive as single when i installed, then i returned the xp drive, maybe it's the reason, can you explain more plz, i'll become then /etc/fstab file then what.

bob
5th April 2006, 01:24 AM
Here's Jim's how-to, which is pretty much what you've done: http://www.fedorajim.homelinux.com/ And, please make sure you've connected the drives as master & slave not as 'cable-select'. I think that's a common problem.

ramimgh
5th April 2006, 01:31 AM
permission denied, that what i get, i started logical volume management, and here it is:http://www.badongo.com/pic/145089

bob
5th April 2006, 02:41 AM
If root's only one gig, there's something wrong with the partitioning. Looks like you should reinstall and use the default partitions. Swap space should be roughly double your ram, but no more than a gig total, which should leave you with plenty for a normal installation. This time through, you might want to do a 'custom' install instead of just the 'desktop' and pick and choose which programs you'll want. Go into the 'details' in each category which would outline some info on the particular programs. You might be able to free up some space that way too.

Make sure you've given yourself a root password and added yourself as a user too.

Now, as to editing your /etc/fstab, you'll need to sign into a terminal as root by typing 'su -' and giving your password (that space and minus sign are important). Then 'gedit /etc/fstab' and a window will open allowing you to edit, add your partitions and save your settings, then exit root and close the terminal.

MetalMan
5th April 2006, 03:06 AM
First, create yourself a folder in which to mount the drive, and BACK UP your current fstab file just in case it gets messed up.

Based on your screenshot, the line that you want to add to your fstab file is this:


/dev/hda1 /winhd vfat user=youruser, rw 0 0

In this, /dev/hda1 is the device to mount (I got this from your screenshot, so this should be the device you're trying to mount). /winhd is the folder that you want to mount the drive to. This can be anything, just make sure that you've already created the folder. vfat is the filesytem type; make sure you use this. user=youruser gives you access to the drive. Put your user name in the place of youruser. If you've got more users that need to have access to it, hopefully someone here knows, because I would like to know that myself. rw allows you to read and write to the drive. If you want to just be able to read the drive, replace rw with r . Finally, 0 0 is something else. I don't yet know what that's there for.

When you do this and save, you should be able to mount the drive by typing

mount /dev/hda1
(or)
mount /winhd

in your console.