PDA

View Full Version : Firefox and Flash Plugin Problems



Sticky
4th April 2006, 04:57 AM
I responded on a similiar thread but thought I would open my own as well.

I have this very crazy problem that has reproduced itself on two seperate machines.
Running FC5 with default Firefox 1.5.0.1 installed in /usr/lib/ I run into the problem of Fox not recognizing the installation of Flash Player 7.0.
I have ran the RPM package installer to no avail as it installs in ./mozilla/ and no where else.
After copying the plugin files to the ./plugins/ folder manually Fox still does not recognize the plugin.
I can tell this by not only going to a website using flash but also through about:firefox, it doesn't show up on the plugin list.
Warren's yum repo for flash also hasn't worked out for me. Every website I go to still tells me I need to install the Flash plugin.
I'm completely stuck, I'm still new to Linux but feel as if I have done pretty well in trouble shooting this problem.

Tell me if I'm being a stupid newb and missing something obvious.

Thxs in advance for the help!

rstrong30
15th January 2007, 07:43 AM
Your not stupid... Firefox is! I'm having the same problem. I'll let you know if I find something.

rstrong30
15th January 2007, 08:09 AM
This worked for me on FC6.

1. wget http://macromedia.mplug.org/macromedia-i386.repo
2. cp macromedia-i386.repo /etc/yum.repos.d/
3. yum install flash-plugin
4. restart firefox
5. type "about:plugins" in browser and look for flash
6. last... try flash site!

eldje
15th January 2007, 12:28 PM
jup worked for me on FC5 ... tnx ;-)

raremon
17th January 2007, 06:42 AM
I don't knwo why its not working on my computer... is it working on 64bit pcs? I tried that and what happened is that yumex didn't push through... instead, it popped out a warning needed to be debugged... please help... thanks...

alpha645
17th January 2007, 02:17 PM
I don't knwo why its not working on my computer... is it working on 64bit pcs? I tried that and what happened is that yumex didn't push through... instead, it popped out a warning needed to be debugged... please help... thanks...

I suggest you use the 32-bit. I also have an 64-bit CPU, but these days, it's useless. Java and many other programs simply don't work.

stlouis1
17th January 2007, 07:15 PM
This worked for me on FC6.

1. wget http://macromedia.mplug.org/macromedia-i386.repo
2. cp macromedia-i386.repo /etc/yum.repos.d/
3. yum install flash-plugin
4. restart firefox
5. type "about:plugins" in browser and look for flash
6. last... try flash site!


wouldn't that just install the rpm here?
http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-9.0.31.0-release.i386.rpm

alpha645
17th January 2007, 08:53 PM
wouldn't that just install the rpm here?
http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-9.0.31.0-release.i386.rpm

Probably, but yum will also automatically look for updates.

raremon
18th January 2007, 11:26 AM
I suggest you use the 32-bit. I also have an 64-bit CPU, but these days, it's useless. Java and many other programs simply don't work.

does this mean that flash and other programs will simply not work on 64-bit cpu?

alpha645
18th January 2007, 03:19 PM
does this mean that flash and other programs will simply not work on 64-bit cpu?

Well, there are exceptions. But the chance you get everything to work under 64-bit is very small.

raremon
19th January 2007, 06:25 AM
Well, there are exceptions. But the chance you get everything to work under 64-bit is very small.

wow... what a chance! anyways, thanks for that information... now I know I can't play flash on my PC at office... hehe... thanks...

alpha645
19th January 2007, 07:22 AM
wow... what a chance! anyways, thanks for that information... now I know I can't play flash on my PC at office... hehe... thanks...

Remember one thing, some stuff does work sometime. So it's alway worth trying :)

fedora1953
20th January 2007, 12:23 AM
Adobe does have the Flash Player for the Firefox / Seamonkey browsers. It can be downloaded from: http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash&P2_Platform=Linux&P3_Browser_Version=Netscape4

Download the Option 1: .tar.gz
After the download is complete click on the “install_flash_player_9_linux.tar.gz” icon. Your Archive Manager will then open. After is does, click on the “Extract” icon. It will ask you where to extract the folder. After doing that, click the Extract button. It will extract the “install_flash_player_9_linux.tar.gz” you had downloaded into 4 files. Open that folder and click on the “flashplayer – installer” A window will open asking if you want to “Do you want to run "flashplayer-installer", or display its contents?”
Click on the button that reads, “Run in Terminal.” Follow the prompts and you are finished.

joe.pelayo
20th January 2007, 12:33 AM
Try to disable SELinux, that worked for me once.