PDA

View Full Version : Fedora Core 5 and Opera



oldoak
3rd April 2006, 07:29 PM
I have recently upgraded from Fedora Core 4 to Fedora Core 5. Prior to upgrading my Opera browser worked beautifully. Since upgrading, the following message appears every time I start Opera:

> "Opera encountered a problem during plug-in setup.
> Plug-ins will not work properly.
> Check your installation.
>
> Could not start plug-in executable 'operamotifwrapper'.
> /usr/lib/mozilla/plugins/operamotifwrapper-3
> Please install Motif.
>
> Plug-in path
> (Path can be modified in Preferences dialog)
>
> /usr/lib/opera/plugins
> /usr/lib/mozilla/plugins"

I have openmotif-2.3.0-0.1.9.2 and openmotif-devel-2.3.0-0.1.9.2 installed.
following are my Opera plugins:
flashplayer.xpt
libflashplayer.so
libnpp.so
operamotifwrapper-3
jre1.5.0_06
libjavaplugin_oji.so
operamotifwrapper-2
operaplugincleaner

and my Mozilla plugins:
flashplayer.xpt
mplayerplug-in-gmp.xpt
mplayerplug-in-rm.xpt
mplayerplug-in.xpt
libflashplayer.so
mplayerplug-in-qt.so
mplayerplug-in.so
nphelix.so
libjavaplugin_oji.so
mplayerplug-in-qt.xpt
mplayerplug-in-wmp.so
nphelix.xpt
mplayerplug-in-gmp.so
mplayerplug-in-rm.so
mplayerplug-in-wmp.xpt
nsdejavu.so

I am requesting suggestions to make my Opera plugins work.
Thank you in advance.

Lluisanunez
3rd April 2006, 07:58 PM
Curious. I had this problem (exactly same message) when I installed FC4. I removed and installed again openmotif and openmotif-devel. I made this link:

ln -s /usr/lib/opera/plugins/operamotifwrapper-3 /usr/lib/mozilla/plugins
And now all my plugins work all right

Admira98
6th April 2006, 11:09 AM
ln -s /usr/lib/opera/plugins/operamotifwrapper-3 /usr/lib/mozilla/plugins
That doesn't work for me.

I used the hint in the opera board:

I have openmotif 2.3.0-0.1.9.2 (with devel) ...Had no luck, until I found some info own my own and decided to try a dirty little trick. First day with FC5 so who cares if I break stuff :wink: "ldd /usr/lib/opera/plugins/operamotifwrapper-2" or "ldd /usr/lib/opera/plugins/operamotifwrapper-3" show what files the both files need.
With this dist and versionnumber of motif there is 2 files in /usr/lib, libXm.so.4.0.0 and libXm.so.4 (that is linked to libXm.so.4.0.0).
Try "ln -s libXm.so.4.0.0 libXm.so.2" or "ln -s libXm.so.4.0.0 libXm.so.3", or both... so far I haven't seen any differens by choosing either one...or even both. The only thing needed is to point to the "too new version" of motif. Anyway...flash and stuff works.

Lluisanunez
6th April 2006, 11:39 AM
mhmhmh... Opera 8.54 is out. Give it a try...

oldoak
7th April 2006, 04:46 AM
That doesn't work for me.

I used the hint in the opera board:

Thank you very much Admira98, I did the following link:

ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3

and Opera is now able to use its plugins.

stanmc
8th April 2006, 01:01 AM
Thank you very much Admira98, I did the following link:
ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3
and Opera is now able to use its plugins.

The link above worked for me also. Opera also tells me that there is a new version 8.54. However it only lists versions for FC3 and FC4. I think this has been answered, but I'm unable to find confirmation of the idea of installing the FC4 version under FC5. Anyone got any comments/suggestions on that?

Used rpm -Uvh and it installed without a hitch. Guess I'm just too cautious

gavinw6662
8th April 2006, 08:06 AM
Thank you very much Admira98, I did the following link:

ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3

and Opera is now able to use its plugins.


I had a crazy time trying to get opera to work on FC4. Well I got it to work, it was the plugins that was holding me back. Hopefully the above info will make it work. I guess I better reinstall it now.

daywalker
9th April 2006, 06:23 AM
during installation it reported the icons are missing.

how do i get back the opera icons?

thnx

chokolandivar
2nd May 2006, 03:07 AM
ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3 was the solution to my problems. thanks guys.

LightsOut
2nd May 2006, 06:40 AM
didn't work for me :(. do i have to reboot? i also did the ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3 thing as root.

LightsOut
5th May 2006, 09:40 PM
downloaded the 9.0b and all is well